Error installing libpicoipp (>= 1.3.0-4r78) on a raspberry pi 4

Post your Linux discussions here
Post Reply
asawho
Newbie
Posts: 0
Joined: Tue Apr 13, 2021 6:37 pm

Error installing libpicoipp (>= 1.3.0-4r78) on a raspberry pi 4

Post by asawho »

I have a raspberry pi 4 with the most recent raspbian lite installed. I followed the directions here, https://www.picotech.com/downloads/linux, to add the repositories. After adding, I ran this and got the following results.

sudo apt install libps5000a

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libps5000a : Depends: libpicoipp (>= 1.3.0-4r78) but it is not installable
E: Unable to correct problems, you have held broken packages.


When looking in the https://labs.picotech.com/debian/pool/m ... ibpicoipp/ folder, the most recent/only armf file is,

libpicoipp_1.1.2-4r56_armhf.deb 2019-05-22 09:38 875K

If I install an older version manually, with these commands it installs without complaint. (NOTE I have not been able to actually test it against a physical picoscope yet to see if the older version works as installed)

wget https://labs.picotech.com/debian/pool/m ... _armhf.deb
wget https://labs.picotech.com/debian/pool/m ... _armhf.deb
sudo apt install libpicoipp_1.1.2-4r56_armhf.deb
sudo apt install libps5000a_2.1.17-5r1443_armhf.deb

Is there something I need to do differently to get the most recent version of the sdk/libraries?

Post Reply