2204A Switching channels A and B during sweep!

Post any questions you may have about our current range of oscilloscopes
Post Reply
picoBill57
Newbie
Posts: 0
Joined: Tue Mar 09, 2021 3:21 pm

2204A Switching channels A and B during sweep!

Post by picoBill57 »

Hello and Help Please!

Bill, Test Engineer; using Picoscope 2204A and Hantek Current probes for diagnosing my car.
Attached files show the "channel swap".

Probe on the starter wire and either a current probe or a back-probe on the coil.
Setting the levels, etc. Occasionally got a good trace, but more likely it randomly swapped the locations and colors of the inputs for channel A and B during the sweep.

It looks like the channel A signal was transferred to the channel B trace throughout the sweep.

Ambient temperature about 40 degrees F.
Happened with or without a reference on the car, laptop on battery, etc. Amplitude and coupling was copied from channel A to channel B, but very slightly smaller, as the two traces can be brought level on the screen and the result basically contiguous (need to zoom in to look at the translation, it was after 0100 !).

Next is to try on the bench to replicate. This scope stays in a box for Auto tools and has had little other use.

Thanks,
Bill
Attachments
RCT-no_sync-Screenshot 2021-03-09 003812.png
RCT-Cold-Channels_Switchng-Screenshot 2021-03-09 000140.png

Al514
Newbie
Posts: 1
Joined: Sat Oct 17, 2020 3:00 am
Location: North Carolina, US
Contact:

Re: 2204A Switching channels A and B during sweep!

Post by Al514 »

Very odd, but if I had to guess, that noise in there has something to do with it. Like your scope is shorting out channels inside . That blue trace is nice and clean, but then you get your swapping and that noise. Definitely try with something that is solid. Like just a 5 volt square wave at a fixed frequency and see if you get the same effect. Also try a different usb cable on your scope, they cause all kinds of issues. Actually that's where I'd start. Hope ya figure it out.

Post Reply