Install picoscope SDK on Raspberry Pi 4

Post general discussions on using our drivers to write your own software here
Post Reply
MkUrbs
Newbie
Posts: 0
Joined: Mon May 07, 2018 6:11 pm

Install picoscope SDK on Raspberry Pi 4

Post by MkUrbs »

Hello everyone,

I need support to install the picoscope SDK (in C/C++) on my Raspberry Pi 4B (O.S. Linux raspberrypi 5.10.11).
[I have already installed the PicoLog 6 and it works perfectly with my picoscopes series 2000 and 4000.]

First question: Is it possible to install the SDK? (I read that the drivers are in beta version)

Second question: How can I do that ? ( I have tried to follow the instructions on the website but without success)

-> using " sudo apt-get install libps2000a", I received this error message
"The following packages have unmet dependencies:
libps2000a : Depends: libpicoipp (>= 1.3.0-4r78) but it is not installable
E: Unable to correct problems, you have held broken packages."

-> I tried to install manually the libraries (armhf.deb) but running the ./autoconf.sh to compile the picosdk-c-example I received this error message "checking for ps2000aOpenUnit in -lps2000a... no
configure: error: libps2000a missing!"

Could you please provide me the instructions to install correctly the SDK?
Thank you very much!

Post Reply