Python PicoVNA 106 Issues

Post general discussions on using our drivers to write your own software here
Post Reply
AdeAyilaran
Newbie
Posts: 0
Joined: Tue Feb 16, 2021 4:17 pm

Python PicoVNA 106 Issues

Post by AdeAyilaran »

Operating System: Windows 10 64-bit
Language: Python 3
IDE: Pycharm Community

Good afternoon,

I’m having some issues with trying to get the API to run correctly using programming methods. Below is an overview of the code:

https://prnt.sc/zutud8

I have a calibrationkit file in the same folder as the code and the API functions are able to pick it up. The kit itself was a simple S11 Load/Open/Short calibration. When I use the PicoVNA2 software to visualize the antennae (S11)I am testing, I get this:

https://prnt.sc/zuty2q

However when I run the Python API code for the S11 logmag, I get this:

https://prnt.sc/zuu0s7

Its just a straight line and I can’t tell if the code is actually reading the signals from the antennae that is connected to my port1. There is also a lack of coding examples for this API that is making it difficult to make progress.

I also redid my calibration to include port2 and a non-insertable DUT. PicoVNA2 software gave me this for the S11:

https://prnt.sc/zuubam

But when I run the Python code, I get this:

https://prnt.sc/zuuu46


Again a straight line with no data. Could you please shed some light on this issue as I'm not sure what I'm doing wrong. My plan is to automate data collection using Python and its like I'm falling on the first hurdle with no help.

Best regards,
Attachments
antennae.png
antennae.png

Post Reply