ps5000a: Incorrect # of shots while using ps5000aSetSigGenBuiltInV2 to generate random bursts using PRBS operation

Post general discussions on using our drivers to write your own software here
Post Reply
amino
Newbie
Posts: 0
Joined: Mon Sep 16, 2019 4:18 pm

ps5000a: Incorrect # of shots while using ps5000aSetSigGenBuiltInV2 to generate random bursts using PRBS operation

Post by amino » Mon Mar 30, 2020 4:45 pm

We have been trouble shooting with the PicoScope 5000a. Our desired goal is to be able to output 120 bursts, on a random changing interval, where the the minimum and maximum intervals between the bursts are set by a minimum and a maximum frequency.

We calculated min and max frequency as
min frequency = 1/(longest desired time between bursts)
max frequency = 1/ (shortest desired time between bursts)

This worked to space out time between burst to random time between min and max frequency. HOWEVER.

We are setting the scope total shots to 120, but we only get about ~40 shots total when observing the output.

We are wondering if we may have set some paramaters to be incorrect, here is the paramaters we passed into ps5000aSetSigGenBuiltInV2 :

handle, #Pass in the handle
offsetVoltage, # set to 1V
pkToPk, # set to [250,000 microvolts]
waveType, # set to PS5000A_SQUARE
startFrequency, # min frequency = 50 Hz = (1/0.02 ms )
stopFrequency, # max frequency = 500 Hz = (1/0.002 ms )
increment, # set to 0
dwellTime, # set to 10 ms ( the period each square wave high output should be)
sweepType, # set to PS5000A_DOWN
operation, # set to PS5000A_PRBS
shots, # ISSUE IS HERE: Set to 120, but only outputs a third of the total bursts it should
sweeps, # set to 0
triggerType, # set to PS5000A_SIGGEN_RISING,
triggerSource, # set to PS5000A_SIGGEN_EXT_IN
extInThreshold # set to (0.75 V converte to adc counts)

Any suggestion on what is being done wrong to have the scope output about a third of the bursts we set it to output? Any suggestions are welcome .

Thanks!

Post Reply