PS 2204A poblem on Raspberry Pi and Ubuntu as well

Post your Linux discussions here
Post Reply
stenczelt
Newbie
Posts: 0
Joined: Tue Feb 18, 2020 4:41 pm

PS 2204A poblem on Raspberry Pi and Ubuntu as well

Post by stenczelt » Tue Feb 18, 2020 4:51 pm

I am trying to use a picoscope with a raspberry pi 3 Model B V1.2. How to make this work? Please see the trace and the steps taken so far.

The driver was installed with the first 3 steps of the download page: `https://www.picotech.com/downloads/linux` and running `sudo apt-get install libps2000` as suggested for raspbian. This is giving the needed .so file in /opt/picoscope/lib. Plugging the machine in, and running `./opt/picoscope/share/doc/libps2000/usbtest` gives me the following output:

Code: Select all

"Pico USB device found: /dev/bus/usb/001/006

 - It belongs to root (which is not you) who has permissions rw-
 - The members of group root (which you are not in) have permissions rw-
 - Everyone else (this is you) has permissions rw-
 - You can write to this device and so will be able to use it."

Installing the python package and running the relevant test (ps2000BlockExample.py) the code fails on line library.py:line71, not finding the C library. Then explicitly referencing the C lib file as:

library.py:line67 changed to:

Code: Select all

library_path = find_library("/opt/picoscope/lib/libps2000.so.2.0.0")
The error is then in the api call:

Code: Select all

[...]functions.py", line 174, in assert_pico2000_ok
    raise PicoSDKCtypesError("Unsuccessful API call")
Testing the same on a laptop (Dell XPS 9360) the error is only in the API call, no need to change library.py. Trying the picoscope program, downloaded as the 4th step of the installation on the website, there is an error as well, from which the trace.xml has been included here.

The latter program cannot be installed on the raspberry pi, with hte following errors:
```

Code: Select all

pi@raspberrypi:~/picosdk-python-wrappers/ps2000Examples $ sudo apt-get install picoscope
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 picoscope : Depends: picomono (>= 4.6.2.16-1r02) but it is not installable
             Depends: libpicoipp (= 1.3.0-4r21) but it is not going to be installed
             Depends: libpl1000 (= 2.0.0-1r570) but it is not going to be installed
             Depends: libps2000 (= 3.0.0-3r570) but 3.0.17-3r1444 is to be installed
             Depends: libps2000a (= 2.1.0-5r570) but it is not going to be installed
             Depends: libps3000 (= 4.0.0-3r570) but it is not going to be installed
             Depends: libps3000a (= 2.1.0-6r570) but it is not going to be installed
             Depends: libps4000 (= 2.1.0-2r570) but it is not going to be installed
             Depends: libps4000a (= 2.1.0-2r570) but it is not going to be installed
             Depends: libps5000 (= 2.1.0-3r570) but it is not going to be installed
             Depends: libps5000a (= 2.1.0-5r570) but it is not going to be installed
             Depends: libps6000 (= 2.1.0-6r580) but it is not going to be installed
             Depends: libusbdrdaq (= 2.0.0-1r570) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
```
Attachments
trace.xml
(4.41 KiB) Downloaded 115 times

Post Reply