Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Having problems ? let us know the details here
Post Reply
davidhigton
User
User
Posts: 5
Joined: Mon Feb 03, 2020 8:18 pm

Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by davidhigton »

My Picoscope 2204A arrived on Saturday. I installed the software under Ubuntu 18.04 and everything worked. However, today when I run the software, it can't find the Picoscope and invites me to connect a demo device instead.

lsusb shows a device 0c01:1007 with no text string against it, when the scope is plugged in, so I know Ubuntu is seeing it at at least a basic level.

It was originally plugged in via a hub. To see if the problem was caused by low power (the hub isn't powered), I plugged the scope straight into the computer, but there's no difference to the symptoms or observations. Also restarting the computer has made no difference.

There have been OS updates since Saturday; in particular there was a very big update to Wine just now, although I don't think that ought to make any difference.

Any help would be welcome!

Martyn
Site Admin
Site Admin
Posts: 4016
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by Martyn »

Please email support@picotech.com as 0ce9 is the Pico vendor ID so something is wrong if it is reporting 0c01

Are you connecting directly into the PC, and with the supplied USB cable?
Martyn
Technical Support Manager

davidhigton
User
User
Posts: 5
Joined: Mon Feb 03, 2020 8:18 pm

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by davidhigton »

See original posting for connection details.

I've tried plugging it into another computer with a totally different OS, and the VID is still showing up as 0c01.

In all cases the original cable is the only one I've used.

Martyn
Site Admin
Site Admin
Posts: 4016
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by Martyn »

Sorry for missing the rest of your original reply, I was using a phone when approving and replying to the post.

If the other O/S was a Windows machine then check what is reported in Device Manager, then drop an email to support@picotech.com as we may need to see the unit to reprogramme it
If it was Linux then email the details. and log files and the team can check the lower level system libraries have not been affected by any updates.
Martyn
Technical Support Manager

davidhigton
User
User
Posts: 5
Joined: Mon Feb 03, 2020 8:18 pm

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by davidhigton »

Email to support sent.

davidhigton
User
User
Posts: 5
Joined: Mon Feb 03, 2020 8:18 pm

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by davidhigton »

More than 24 hours have elapsed, and there has been no reply to my support case other than a standard auto-acknowledgement.

Further up this thread, you asked me to "email the details. and log files". This is too vague for me. Which details and log files do you want, and where will I find them? (Ubuntu 18.04.4 LTS, fully updated.)

tortoise
Newbie
Posts: 1
Joined: Sat Feb 15, 2020 10:25 am

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by tortoise »

Hi, any update on this issue faced with 2204A and Ubuntu 18.04 LTS? Was it resolved and what was the problem, if any?

I've been considering a Picotech for a few weeks now and being a Linux user trying to anticipate as many problems encountered with Linux as I can before the purchase. I've found with Linux it's the only way - to be aware of the issues because there will be some. I do feel satisfied when I get around them though.

davidhigton
User
User
Posts: 5
Joined: Mon Feb 03, 2020 8:18 pm

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by davidhigton »

PicoTech replaced the 'scope FOC after declaring it uneconomic to repair.

It was a bizarre fault; the USB Vendor ID had changed! Nobody knows how that's possible. USB was still basically working, as I could see output from it from lsusb -v. I've never known a fault anything like it in all my (many!) years of electronics experience.

So it's not a systemic problem; it was just a bizarre fault with that particular specimen of 2204A.

I should add that the replacement is working beautifully. The Linux software has also had an update very recently. I mentioned elsewhere in this forum that Manchester decoding was missing, and it's appeared in the update.

MaxPu
Newbie
Posts: 1
Joined: Mon Jun 22, 2020 2:45 pm

Re: Picoscope 2204A seen once under Ubuntu 18.04, doesn't work today

Post by MaxPu »

Exactly same Issue on a Picoscope 2205A. Worked fine till 5 days ago. Same strange behaviour. Unknown Device.
New USB-Hardware-ID: USB\VID_0C01&PID_1007&REV_0005 and USB\VID_0C01&PID_1007.

No answer from picotech until today.

Post Reply