Unable to run PicoLog 6 on Raspberry Pi

Having problems ? let us know the details here
Post Reply
Posts: 1
Joined: Mon Jan 27, 2020 1:55 am

Unable to run PicoLog 6 on Raspberry Pi

Post by MapleMan » Mon Jan 27, 2020 2:20 am

Let me preface this by saying that I'm very new to all things Raspberry Pi/Raspbian/Debian.

I'm trying to use a Raspberry Pi 3 and TC-08 together as a small-scale temperature logger. I've followed the instructions on the Pico downloads site for Raspbian which are:

1. Download the deb file (picolog-6.1.14-armhf.deb).
2. Open a terminal and import the public key

wget -O - https://labs.picotech.com/debian/dists/picoscope/Release.gpg.key | sudo apt-key add -

3. Install PicoLog 6

sudo dpkg -i picolog-6.1.14-armhf.deb

All of which work fine. However, when I try to launch the PicoLog 6 software from the accessories menu, nothing happens, except the hourglass symbol appears for about 5 seconds then disappears. When I try to launch the software manually by navigating to /opt/PicoLog 6 and executing "picolog" I get the same result. I've also tried running it through terminal using ./picolog and all I get is a segmentation fault.

Anybody know where I'm going wrong?

Posts: 1
Joined: Mon Apr 20, 2020 3:43 am

Re: Unable to run PicoLog 6 on Raspberry Pi

Post by fmilburn » Mon Apr 20, 2020 3:51 am

I am new to the picologger also but there is now a version 6.1.15. I am able to use it without problems on a Raspberry Pi 4. You might try downloading that version and installing.

Note to Pico: The download page button for Rasbian installation of Picolog correctly links to the latest version 15 but the instructions below will try to install version 14.

Post Reply