Bit Resolution Enhancement not persistent

Discussion forum for the Picoscope 6 Linux software
Post Reply
RTFM@1984
Newbie
Posts: 0
Joined: Sun Jul 07, 2019 10:09 pm

Bit Resolution Enhancement not persistent

Post by RTFM@1984 »

When changing the Bit Resolution Enhancement setting with software version 6.13.7 from the default 8.0 bits to 12.0 bits (or any other resolution), the new setting is executed when changed and kept when the small window is closed. But when again clicking on the Channel Options for "A", the resolution enhancement shows again 8.0 bits.

I would expect it stays and be visible. This looks like a bug.

Can someone please confirm this?

Thanks in advance.

Marc
Attachments
20190830_bit_resolution.png

Martyn
Site Admin
Site Admin
Posts: 4017
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Bit Resolution Enhancement not persistent

Post by Martyn »

Is it still operating in 12bit even though the display is on 8bit, if so this may be linked to the selected state value for the drop down menu.
Martyn
Technical Support Manager

RTFM@1984
Newbie
Posts: 0
Joined: Sun Jul 07, 2019 10:09 pm

Re: Bit Resolution Enhancement not persistent

Post by RTFM@1984 »

It is operating in 12 bit, but it does not show it as such. Furthermore, once opening the window for a second time, it jumps back to 8 bit. This means settings needs to be set again.

The persistency problem not only applies to the bit resolution enhancement, but also to other settings like bandwidth limiter.

RTFM@1984
Newbie
Posts: 0
Joined: Sun Jul 07, 2019 10:09 pm

Re: Bit Resolution Enhancement not persistent

Post by RTFM@1984 »

The clarify further, on Ubuntu 18.04 with 6.13.7.707 settings do persist but in the configuration settings for channel A settings are always reverted to the default state when reopening that window.

Post Reply