PicoLog with CM3 via Network Linux

Forum for discussing PicoLog
Post Reply
LinuxUser13
Newbie
Posts: 0
Joined: Sun Jul 21, 2019 12:18 pm

PicoLog with CM3 via Network Linux

Post by LinuxUser13 » Sun Jul 21, 2019 12:56 pm

I just got y CM3 with 3 clamp delivered. The main USP was EthernetPoE and Linux support (we have only 1 Windows PC left)

I was quite surprised to learn during setup that while the software PicoLog6 looks and feels the same for Windows and Linux there is 1 difference: The Linux version does not have the menu entry "Ethernet Devices". I re-checked the marketing pages and product pages (also amazon) and that is never mentioned there. How on earth would someone expect that sending and receiving Ethernet packets would be different between Linux and WIndows?
Our use case is to hook up the CM3 with a PoE switch anythere on the site and so the recording from anywhere.

I would be interested to learn more about that decision and about the technical issues behind it.

- I ran a wireshark trace confirming the info I found in another thread about rather simple and short binary UDP packages. I connected an Ehternet enabled CM3 via USB to Linux and recorded there. When I connected it to the LAN as well, I could switch into the recording via Ethernet on the WindowsPC. It just polled the device and displayed the stream. I can not really see why that should not be possible in Linux.


Are there any workarounds?
- this thread ( https://www.picotech.com/support/topic22661.html?&p=73881&hilit=CM3#p73881 ) is about "CM3 data logger via Ethernet using a python wrapper around the libplcm3.so driver". This gives me a bit of hope. On the one hand that the information inthe "CM3 programmers guide" pdf is outdated (SKD is windows only) and on the other hand that the problem might have been solved, just the information is missing.

Thanks for the feedback

Martyn
Site Admin
Site Admin
Posts: 3635
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoLog with CM3 via Network Linux

Post by Martyn » Mon Jul 22, 2019 7:57 am

It is possible to communicate with the CM3 directly using UDP packets with Linux, however the PicoLog 6 application uses the the library files, and the Linux versions do not have support for ethernet connectivity which is why the menu option is missing.

We have feature requests in to look at this, although the work is not currently on the schedule. As with your other post I suggest you email support@picotech.com to discuss this further.
Martyn
Technical Support Manager

Post Reply