Picoscope 6 install into Lubuntu

Discussion forum for the new Picoscope Linux software
Post Reply
RussellSenior
Newbie
Posts: 0
Joined: Wed Mar 19, 2014 5:52 pm

Picoscope 6 install into Lubuntu

Post by RussellSenior »

I'm trying to install Picoscope 6 on Lubuntu. I followed the directions for the Ubuntu install, but it fails on the last step, installing the software. Below is the output from the terminal, and it seems I have some missing dependencies, but I'm not sure how to rectify the situation, any suggestions?

Code: Select all

sudo apt-get install picoscope                                                                              
Reading package lists... Done                                                                                                
Building dependency tree                                                                                                     
Reading state information... Done                                                                                            
Some packages could not be installed. This may mean that you have                                                            
requested an impossible situation or if you are using the unstable                                                           
distribution that some required packages have not yet been created                                                           
or been moved out of Incoming.                                                                                               
The following information may help to resolve the situation:                                                                 
                                                                                                                             
The following packages have unmet dependencies:                                                                              
 picoscope : Depends: picomono (>= 4.6.2.16-1r02) but it is not installable                                                  
             Depends: libpicoipp (= 1.3.0-4r21) but it is not installable
             Depends: libpl1000 (= 2.0.0-1r570) but it is not installable
             Depends: libps2000 (= 3.0.0-3r570) but it is not installable
             Depends: libps2000a (= 2.1.0-5r570) but it is not installable
             Depends: libps3000 (= 4.0.0-3r570) but it is not installable
             Depends: libps3000a (= 2.1.0-6r570) but it is not installable
             Depends: libps4000 (= 2.1.0-2r570) but it is not installable
             Depends: libps4000a (= 2.1.0-2r570) but it is not installable
             Depends: libps5000 (= 2.1.0-3r570) but it is not installable
             Depends: libps5000a (= 2.1.0-5r570) but it is not installable
             Depends: libps6000 (= 2.1.0-6r580) but it is not installable
             Depends: libusbdrdaq (= 2.0.0-1r570) but it is not installable
E: Unable to correct problems, you have held broken packages.

AndrewA
PICO STAFF
PICO STAFF
Posts: 298
Joined: Tue Oct 21, 2014 3:07 pm

Re: Picoscope 6 install into Lubuntu

Post by AndrewA »

Hi,

Can you confirm what version of Lubuntu this is? And if this is a 32-bit or 64-bit version of the OS.
Regards Andrew
Technical Specialist

Decovi
Newbie
Posts: 0
Joined: Thu Feb 20, 2020 11:48 am

Re: Picoscope 6 install into Lubuntu

Post by Decovi »

Hey all,

I have the exact same problem here.
I im running Lubuntu 18.04 on a 32-bit machine.
I hope somebody can fix this problem.
Tanx very much

Post Reply