timeseries stops refreshing/updating

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
derFu
Newbie
Posts: 0
Joined: Mon Jan 28, 2019 9:30 am

timeseries stops refreshing/updating

Post by derFu » Mon Jan 28, 2019 10:02 am

What we are doing:
We are using picoscope to accquire data at slow rates (minutes to hours duration, ~1MS, generally 100kS-5MS). However, the issue doen't seem to be limited to this application but colleagues with different picoscopes running at higher rates (interested in hundreds of kHz) suffer from the same problem.
Problem 1:
Picoscope 6.13 stops very often to refresh the timeseries window after a couple of minutes while a measurement is still ongoing. Don't get me wrong, the data isn't lost. It just won't be displayed until one presses stop. This is very annoying when trying to manually control a system by means of scope data displayed or when taking long term data (50000s) and wanting to judge what is going on in the meantime. Furthermore in conjunction with problem 2 you wont be able to judge whether the few hour datarun was a waste of time because the software crashed completely until you stop the run.
Problem 2:
The software crashes once in a while, especially when changing settings like voltage range or mresuarement duration. This happened with the older sofware way more often (more than once an hour), which is why we don't want to downgrade...
Settings:
- No trigger set.
- We typically use both channels
- PicoScope® 6 - PC Oscilloscope software version: 6.13.11.3952
- Model: PicoScope 4262
- USB Version: 2.0
- Hardware Version: 1
- Driver Version: 2.1.4.789
- Firmware Version: 1.0.5.0 / 1.1.4.0

The workaround of others seems to be to stream data continuously to the disc circumventin the picoscope software. For this, however, we could have bought any arbitrary data accquisition system. :-/ Does anybody have an idea what we could change to make it work? Many thanks in advance.
Tobias

Martyn
Site Admin
Site Admin
Posts: 3583
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: timeseries stops refreshing/updating

Post by Martyn » Thu Mar 07, 2019 9:18 am

Can you please send in a psdata file to support@picotech.com so that we can setup a test to see what the issue may be.
Martyn
Technical Support Manager

Post Reply