5244D functional with USB 2.0

Post any questions you may have about our current range of oscilloscopes
Post Reply
Posts: 0
Joined: Fri Nov 30, 2018 10:20 am

5244D functional with USB 2.0

Post by Mat90 »

I recently bought a Picoscope 5244D.

First of all i want to say that my Code is working when I am connected via a USB 3.0 Cable and use a USB 3.0 Port on PC-side as well.

I have tried using a USB 2.0 Cable as well and I also tried with the delivered USB 3.0 Cable, but on the PC-side plugged in a USB 2.0 Port. When I connect to the pico with the command "ps5000aOpenUnit" I get PICO_USB3_0_DEVICE_NON_USB3_0_POR as return value. In case of that, I call "ps5000aChangePowerSource" with the parameter PICO_USB3_0_DEVICE_NON_USB3_0_POR like it is advised in the programmer manual. This works as expected.

The next step is that I call "ps5000aRunBlock" to collect data of course with a callback parameter and not with null. This results in the problem, that I am not getting data.

So now my question. Is the Picoscope 5244D fully functioning, when it is connected to a USB 2.0 Port on PC-side.

Thank you for your help in advance.


Advanced User
Advanced User
Posts: 2856
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: 5244D functional with USB 2.0

Post by Hitesh »

Hi Mat,

Is there any non-zero code returned when calling ps5000aRunBlock()?

It might be useful to post the code sequences here leading up to the retrieval of data if possible or send it to support@picotech.com

The only thing that should happen when the device is connected on a USB 2.0 port is that the transfer rate of the data from the device to the PC will drop (in streaming mode data collection this would also limit the maximum rate of data collection).


Software Dev. Engineer

Post Reply