TA018 Range only goes to -5A in the negative direction?

Having problems ? let us know the details here
Post Reply
deadlyvapour
User
User
Posts: 2
Joined: Fri Oct 19, 2018 4:32 pm

TA018 Range only goes to -5A in the negative direction?

Post by deadlyvapour » Fri Oct 19, 2018 4:38 pm

The input range programmed into the Picoscope software seems to suggest that the probe only goes down to -5A in the negative direction. This surely can't be right, since it was sold as a 60A AC/DC current probe.

Are the default lookup values incorrect?
Is the probe able to be used with AC currents up to 60A?

Martyn
Site Admin
Site Admin
Posts: 3609
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: TA018 Range only goes to -5A in the negative direction?

Post by Martyn » Mon Oct 22, 2018 12:12 pm

The probe definition you are looking at has come from the Automotive Software, and was setup for the tests that are run in that environment. For Test and Measurement applications you can edit the probe so that it covers the full range.
Martyn
Technical Support Manager

deadlyvapour
User
User
Posts: 2
Joined: Fri Oct 19, 2018 4:32 pm

Re: TA018 Range only goes to -5A in the negative direction?

Post by deadlyvapour » Mon Oct 22, 2018 7:38 pm

I'm a little confused. That application is Picoscope. Are you saying that the definitions are not maintained by Pico Tech, and was instead imported from the Automotive Software?

Martyn
Site Admin
Site Admin
Posts: 3609
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: TA018 Range only goes to -5A in the negative direction?

Post by Martyn » Tue Oct 23, 2018 7:34 am

The probe definition that is used in the PicoScope 6 software has been lifted from the PicoScope 6 Automotive software which does force an asymmetrical view when using the higher ranges. It si appropriate in automotive use due to the type s of test that are carried out using this clamp.

This should not be the case for the standard version so I will raise a bug for this. In the meantime you can manually change this by going into the Tools->CustomProbes menu, duplicate the probe and then edit the probe and change the lookup tables so that they are symmetrical.
Martyn
Technical Support Manager

Post Reply