3406D resets SigGen on acquisition change

Post your LabVIEW discussions here
Post Reply
thofmann
Newbie
Posts: 0
Joined: Fri Sep 14, 2018 12:36 am

3406D resets SigGen on acquisition change

Post by thofmann » Fri Sep 14, 2018 12:58 am

I wrote a metrology program and successfully used it for many years with 3404A and 3406B picos.
Our company recently bought 3406D scopes and the program doesn't work anymore.
The program uses the built-in signal generator to issue a triangular wave at a very low frequency
of 50mHz. It then takes many measurements and frequently changes between block and rapid block
mode. When it changes the block mode it also changes the sampling rate.
With the 3406D scope the signal generator gets reset and starts at zero every time I am changing
between block and rapid block, which means the program cannot measure over the full period
of the SigGen. The older scopes didn't do that and generated a perfect triangle waveform, no matter
what data acquisition was happening at the same time. Is there any way to stop the SigGen from
resetting?
The program is written in Labview2012.
Thx.

Hitesh
Site Admin
Site Admin
Posts: 2810
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: 3406D resets SigGen on acquisition change

Post by Hitesh » Fri Sep 14, 2018 8:25 am

Hi Thofmann,

Could you please post some screenshots of what you are seeing when changing modes? Is the function call to set the signal generator being called every time a change is being made?

Regards,
Hitesh

Technical Support Engineer

thofmann
Newbie
Posts: 0
Joined: Fri Sep 14, 2018 12:36 am

Re: 3406D resets SigGen on acquisition change

Post by thofmann » Wed Sep 19, 2018 10:28 pm

Hi Hitesh,
SigGenBuiltIn is being called at the start of the program and then never again. Below are the input parameters:
name type value
handleIn I16
offsetVoltage I32 9.50E+05
pkToPk U32 1.90E+06
wavetype I16 2
startFrequency SGL 0.05
stopFrequency SGL 0.05
increment SGL 0
dwellTime SGL 1
sweepType I32 0
operation I32 0
shots U32 0
sweeps U32 0
triggerType I32 0
triggerSource I32 0
extInThreshold I16 0
I arrived at some of the inputs by trial and error. They may not be correct or optimal.
3406B.psdata shows the triangle waveform as it should be with the old scope.
3406D.psdata shows the interrupted/reset waveform with the new scope. The program repeatedly takes
9 data sets of block data and 1 data set of rapid block data. Every time it switches between block and
rapid block the waveform gets reset.
The scope is being powered via the USB port, if that matters.
Thomas
Attachments
3406D.psdata
(151.5 KiB) Downloaded 13 times
3406B.psdata
(153.04 KiB) Downloaded 13 times

Hitesh
Site Admin
Site Admin
Posts: 2810
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: 3406D resets SigGen on acquisition change

Post by Hitesh » Mon Oct 15, 2018 9:36 am

Hi Thomas,

Apologies for the delay in getting back to you.

If you update the PicoScope software does the same issue occur? Are the PicoScope 3406B and 3406D units the only ones that you have?

Regards,
Hitesh

Technical Support Engineer

Post Reply