Test and Measurement Forum

Disappointed with Picoscope 5203

Post any questions you may have about our current range of oscilloscopes

Disappointed with Picoscope 5203

Postby Andreas » Mon Feb 25, 2008 2:53 pm

I am sorry to say this but I just purchased a picoscope 5203 and I'm not happy with it.
1) Have a look at my picure, the LED indicator is not aligned with the hole, how can this even be possible on a €1600 device, doesn't anyone check the hardware before shipment?
2) The fan sounds awful, I've spent quite a few hours on getting quiet computers for my office but now the Picoscope on my desktop sounds more than any computer I ever got. Why do you use such a noisy fan? Is it possible to replace it?
3) There's no easy way to invert a channel (software version 6.0.13.3) ??
4) There's no way to show two different views, example: when I load a saved signal and choose "add view" both "scope 1" and "scope 2" shows the old waveform and when I then set the triggring to see the scope input it is displayed in both views.
5) The software doesn't find the hardware after Windows XP hibernation, I have to unplug the USB cable, reconnect it and then start the software.

Looking forward to your response.

Regards
Andreas
Attachments
sm_2008-02-25 11-35-03_0048.jpg
sm_2008-02-25 11-35-03_0048.jpg (18.99 KiB) Viewed 3071 times
Andreas
User
User
 
Posts: 4
Joined: Mon Feb 25, 2008 12:59 pm

Postby alan » Tue Feb 26, 2008 5:53 am

Dear Andreas,

I am sorry to hear of the issues listed. As soon as the office opens today I will arrange for someone to send you a replacement unit and also arrange the collection of your existing unit.

1. The LED should obviously be in line and these sort of things are checked so I am at a bit of a loss as to how this has happened. I do not want to simply blame the delivery company as the chances are we chose the company and packed the product up!

2. As for the fan, they do emit some noise but from your comments it may well be excessive. Again perhaps the unit has taken a knock. We will check when we get the unit back.

3. Channel inversion can be done using custom channels. Open the channel options next to the AC/DC selection and click on the "..." at the end of probes. Select "New Probe" and click Next until you get scaling method.

Where you are offered y=1.0 x + 0 volts put a - sign in from of the 1.0 (its a y=mx+c type scaling). If you choose a name like Invert this will now be available in the drop down list of probe types.

4 & 5. I am in a hotel room without a scope at the moment so can not try these out right now. I will make sure someone gets back to you at start of business.

Apologies again for the trouble with the unit.

Alan
alan
Site Admin
Site Admin
 
Posts: 165
Joined: Thu May 25, 2006 8:02 am

Postby ziko » Thu Feb 28, 2008 9:19 am

Hi Andreas,

I sent you an email to arrange an advanced replacement a couple of days ago, have you recieved it?

If not could you email us at support@picotech.com

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby Andreas » Tue Mar 04, 2008 7:05 am

Sorry for not getting back to you sooner, I'm busy with a project.

2) "Do emit some noise" you say, that's no good, what can be done to make it almost noiseless? What kind of fan are you using, can you assure me that it is of really good quality?

3) Yes, I found that out by myself but that's not easy. A button labeled "Invert Channel" would be easy, don't you agree?

4-5) Are you still at the Hotel room Alan?

Ziko: Yes got your mail, will answer later today.

Regards
Andreas
Andreas
User
User
 
Posts: 4
Joined: Mon Feb 25, 2008 12:59 pm

Postby ziko » Wed Mar 05, 2008 12:50 pm

Hi Andreas,

Hopefully the replacement unit you receive will be less noisy, but all fans emit a certain level of noise. There is a PicoScope 5204 running on my desk at the moment and I can only just hear it, but to be fair we have a heating / ventilation system in the office which does produce some background nosie.

Both points 3 and 4 are on our "to do" list but other than saying they will arrive this year I can not give any firm dates.

Point 5 (XP hibernation) is something we are looking at. I have been told that there are several different hibernate modes for USB, some for example leave USB devices powered so they can wake up the PC others do not. We will make improvements in this area but have to ensure any changes work reliably across different operating systems, USB hubs etc etc.

Hope this helps.
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby Andreas » Tue Mar 25, 2008 11:42 am

Once again sorry for not getting back to you sooner, I'm still busy with a project and we've also had the Easter holiday.

Anyway I opened your package today and now I'm even more disappointed. First of all you sent me a used replacement unit with fingerprints and scratches (my brand new but faulty unit is in mint condition) and secondly you didn't provide a way to return the faulty unit, you seem to expect me to pay the return postage - I won't accept neither. I expect a brand new unit and I expect you to pay the return postage.

Your lack of quality control is causing me a lot of trouble, who will pay for the time I'm wasting handling your packets, checking your equipment and writing this?

As for the fan, the fan in the used and scratched replacement unit sounds as bad as the first one I got. All fans emit a certain level of noise you say, yes that's true but my laptop also includes a fan and the picoscope sounds ten times as much so the problem is not the term "fan", the problem is you using a low-quality fan (possible also poorly placed).

Regarding points 3 & 4, what is so complicated with this that you cannot fix it in a week?

Regards
Andreas
Attachments
2_2008-03-25 10-21-03_0014.jpg
(64.86 KiB) Downloaded 802 times
2_2008-03-25 10-55-44_0006.jpg
(84.66 KiB) Downloaded 799 times
Andreas
User
User
 
Posts: 4
Joined: Mon Feb 25, 2008 12:59 pm

Postby ziko » Tue Mar 25, 2008 4:41 pm

Hi Andreas,

The unit we sent you was an advanced replacement loan unit and not a new unit. We sent this as a temporary replacement whilst we sorted out the problems with your original unit. I appolgise if I did not make this clear in the email.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Postby Andreas » Thu Apr 03, 2008 4:55 pm

No you did not make that clear and it does not make any sense, what is there to sort out with a misaligned LED and a noisy fan other than to just fix it?

You are making things far too complicated.

This is what I would like from you:
1) Fix software points 3-5 ASAP.
2) Send me a brand new unit with the LED in the right place and a fan that makes less noise. (Or give me permission to fix the LED and the fan myself without the warranty being voided.)

Too much to ask?

Regards
Andreas
Andreas
User
User
 
Posts: 4
Joined: Mon Feb 25, 2008 12:59 pm

Postby ziko » Wed Apr 09, 2008 2:33 pm

Hi Andreas,

Sorry that you feel we are making things too complicated. At the moment you have both oscilloscopes. So to make it simple, if you could return both of them to us we will repair your original unit and send it back as soon as possible.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests