Test and Measurement Forum

Assertion failed part two

Post any questions about our parallel port products

Assertion failed part two

Postby oldie » Thu Feb 21, 2008 7:05 pm

I have now spent some weeks attempting to log six different readings from a single DrDAQ remotely connected to either a PC or a laptop, via the Pico parallel port adaptor, a USB extender and 10 metres of CAT 6 cable. After a maximum of say, 48 hours, the monitor displays "Assertion failed" and the log stops. The fault seems to occur when a local PC or monitor is switched on/off or some other activity which either transmits a pulse on the mains or causes an RF airborne transmission. I have tried using mains filters on all connected equipment, changed from CAT 5 to CAT 6 screened cable, and even, to test the USB extender, used the DrDAQ and Pico parallel port adaptor connected directly to the PC/Laptop with just the Pico supplied USB cable. An "Assertion failed" dialogue box still appears frequently even when only using Pico supplied units. I have also added clip-on ferrites on the CAT 6 cable, & the power supply, and the USB extender, none of these having any long lasting cure.

When I use one particular PC to log the readings, the "Assertion failed" display always shows the fault at line 1002, when the expression returns !=0. This is gibberish to me as I am not a Visual C++ programmer.
On other PCs or laptops, the fault occurs on different lines, sometimes four different lines, one "Assertion failed" box after another. Four altogether. This latter occurred when I was switching on an adjacent PC and Monitor. I am very disappointed with the results so far and have abandoned this method of logging the data from the DrDAQ. As suggested by Pico, I am now using an old but reliable PC loaded with Windows XP as a server adjacent to the DrDAQ and using IP Networking for the data logging. Needless to say I am no longer using the parallel port to USB adaptor, (I've tried two different units) but using the DrDAQ connected directly to the PC's parallel port via the Pico parallel cable. It has now been running OK for about 2 hours............
oldie
Active User
Active User
 
Posts: 8
Joined: Thu Aug 09, 2007 7:26 pm
Location: North West London

Return to Parallel Port Products

Who is online

Users browsing this forum: No registered users and 0 guests