New Pico Scope 2105 keeps shutting off automatically

Post any questions you may have about our current range of oscilloscopes
Post Reply
vlfman
Newbie
Posts: 1
Joined: Wed Feb 13, 2008 3:33 pm

New Pico Scope 2105 keeps shutting off automatically

Post by vlfman » Wed Feb 13, 2008 4:34 pm

This is driving me nuts. I have a new PicoScope 2105 and it keeps automatically shutting off on me.

The longer I use the scope, the more quickly it automatically shuts off. The probe does get warm rather quickly and I’m wondering if there is some sort of automatic heat sensor inside that shuts the unit down when it hits a certain temperature. That would be understandable except that after a reasonable amount of use the unit becomes useless because it just won’t stay on.

Need help badly. Thanks for any replies.

- Pete

picojohn
Advanced User
Advanced User
Posts: 382
Joined: Mon Jun 11, 2007 1:10 pm

Post by picojohn » Thu Feb 14, 2008 3:27 pm

Pete,

Please send an email to support@picotech.com for details of how to return the unit for testing.

Regards
John

tirak2
User
User
Posts: 3
Joined: Tue May 13, 2008 7:15 am

Post by tirak2 » Tue May 13, 2008 8:53 am

Hi vlfman.

I wonder if you by saying the scope keeps on shutting off means that it stopps with the red light on?
And to get it going you have to unplug/plug in again?

Have similar problems with a PS2104 that also gets a little warm.

picojohn
Advanced User
Advanced User
Posts: 382
Joined: Mon Jun 11, 2007 1:10 pm

Post by picojohn » Tue May 13, 2008 10:09 am

Hello Tyrak,

The device getting 'a little warm' is not in itself a problem. However, if you are experiencing software lock-up, please try the latest version of PicoScope 6.

Regards
John

Post Reply