Test and Measurement Forum

ADC-40 and software release 5.16 or 5.18

Forum for discussing PicoScope (version 5)

ADC-40 and software release 5.16 or 5.18

Postby Guest » Mon Feb 04, 2008 10:55 pm

I bought an ADC-40 several years ago from Maplins. Tried it on a Dell laptop and encountered problems and recently tried it on an IBM. On both the speed was/is desperately slow with the mouse movements slowed to snail's pace. The scope does work. Then on trying to get a waveform optimised on screen, the software crashes. Windows Task Manager cannot be accessed and the only recourse is a power-off reset.

The symptoms are exacly as Loren noted earlier in January in a previous forum topic although the dignosis and suggested solution was much more complex. The symptoms are not intermitant: a crash every time is guaranteed. I tried both 5.16 and 5.18 but both fail.

The IBM is a Pentium 2GHz with 1.5GByte Ram and XP SP2.


Postby ziko » Wed Feb 06, 2008 3:20 pm

Hi and thank you for you post.

This is because on older products, they do not have any memory within them and as such the timing is dictated by the PC. So the software would block the operating system whilst it is controlling and collecting data from the device. It should not crash though, bearing in mind these products were created in the days of DOS!

You can get round this problem though by purchasing the parallel to USB converter,


This product is designed to work on our and is the only adapter that will work for our products.

Hope this helps.

Kind regards

Technical Specialist
Zen Master
Zen Master
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

Return to PicoScope 5

Who is online

Users browsing this forum: No registered users and 0 guests