Test and Measurement Forum

Can you display the model number somewhere?

Forum for discussing PicoScope (version 5)

Can you display the model number somewhere?

Postby CoyoteDavid » Tue Dec 18, 2007 9:14 am

I have two PicoScopes, a 3424 and a 2105. I switch regularly between them. It would be nice it there was a way I could quickly tell which one is being used, like displaying the model number in the title bar. I know you can get it by entering "Help" --> "About PicoScope", but it would be nice to see it in the title bar to the right of "PicoScope 6", or somewhere...

Also, I noticed that when I switched from the 3424, which has 10x probes on it, to the 2105, PicoScope comes up with the 2105 as a 10x probe. Given that the 2105 has a fixed probe attached, shouldn't it default to x1? Should you even be able to set it for a 2105?

It would be nice if PicoScope could keep some of its configuration data in model specific locations. Is there a way to do that? Would sure save me some configuration time every time I swap scopes.

Also, why is the sample rate only allowed to be divided by a power of 2? (Like 1, 2, 4, 8, 16, etc.) The rates would work out much better if it allowed the normal 1, 2, 5, 10, 20, 50 etc., allowing for much better utilization of the memory buffer.
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Postby ziko » Tue Dec 18, 2007 9:48 am

Hi CayoteDavid I will forward your suggestion through to the relevant people.

In terms of the probe problem, did you load a setting file? As every time you load the software it clears the previous settings.

The reason why the sample rates is divided by 2 is purely the way it is done within the FPGA.

Hope this helps.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

PicoScope 6 settings files

Postby CoyoteDavid » Tue Dec 18, 2007 6:38 pm

I use PicoScope 6, and the only setting file I see is the "startup settings", of which there is only one. If I set that for the 3424, it is wrong for the 2105, and vice versa. Is there a way to get named settings files?
CoyoteDavid
Active User
Active User
 
Posts: 17
Joined: Fri Jan 05, 2007 7:48 am
Location: California

Postby ziko » Wed Dec 19, 2007 9:26 am

Hi this is performing as it is intended. Whatever settings you choose are for the software and not specific to the hardware.

However you can save a settings file, so when you have "Save Current Waveform As" you can then change the file extension to .pssettings and then you can load this file for your specific device.

Hope this helps

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to PicoScope 5

Who is online

Users browsing this forum: No registered users and 2 guests