Matlab doesnt find picoscope

Having problems ? let us know the details here
Post Reply
thedries
User
User
Posts: 4
Joined: Thu May 24, 2018 4:49 pm

Matlab doesnt find picoscope

Post by thedries » Thu May 24, 2018 4:57 pm

Hello,

First time i am trying to use Picoscope.
It works in the picoscope.exe Gui, but i really would like to use it in my matlab script.

Matlab gives me the following error:

Warning: Disconnect: No devices found.
Error using icdevice (line 283)
An error occurred while executing the driver create code.
Status code: 268435457

If the error is not an instrument error, use MIDEDIT to inspect
the driver.

Error in PS6000_ID_Block_Example (line 72)
ps6000DeviceObj = icdevice('picotech_ps6000_generic.mdd', '');


I have the SDK 7.1 installed, and also i have the picoscope support toolbox. Why matlab doesn't find the picoscope? Any idea how i can make this work?

thanks,
Theo

Hitesh
Site Admin
Site Admin
Posts: 2847
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Matlab doesnt find picoscope

Post by Hitesh » Fri May 25, 2018 8:42 am

Hi Theo,

Which version of MATLAB are you using? Have you installed the 32-bit/64-bit PicoSDK according to the version of MATLAB you are using?

Did you install the Instrument Driver package and PicoScope Support Toolbox via the Add-Ons Explorer in MATLAB?

Regards,
Hitesh

Software Dev. Engineer

thedries
User
User
Posts: 4
Joined: Thu May 24, 2018 4:49 pm

Re: Matlab doesnt find picoscope

Post by thedries » Fri May 25, 2018 6:14 pm

Hi Hitesh,

thanks for replying.
I rebooted the computer, and now it works fine.

I nearly set it up as i want, the only thing i don't know how to change the number of samples.

best,
Theo

Hitesh
Site Admin
Site Admin
Posts: 2847
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Matlab doesnt find picoscope

Post by Hitesh » Tue May 29, 2018 12:55 pm

Hi thedries,

Good to hear its working.

The following is taken from the streaming example for the Instrument Driver:

Code: Select all

set(ps6000DeviceObj, 'numPreTriggerSamples', 0);
set(ps6000DeviceObj, 'numPostTriggerSamples', 5000000);
You can add this code to your example and modify it to suit your application. Note that if you do not set the a trigger, the device will collect the number of pre- and post-trigger samples.

Regards,
Hitesh

Software Dev. Engineer

thedries
User
User
Posts: 4
Joined: Thu May 24, 2018 4:49 pm

Re: Matlab doesnt find picoscope

Post by thedries » Wed Jul 11, 2018 8:24 pm

Hello Hitesh,

i am now installing a Picoscope 4284 on matlab 2016b and i am again experiencing difficulty to find the scope from matlab. I tried rebooting, which worked for me last time, but it won't help.

Warning: Disconnect: No devices found.
Error using icdevice (line 313)
An error occurred while executing the driver create code.
No units found.
If the error is not an instrument error, use MIDEDIT to inspect the
driver.



I installed the 64 bit SDK toolbox, then I had some trouble using the add-on installer from matlab, so i downloaded the PS4000 matlab instrument driver and the picotech support toolbox from mathworks and github respectively. Both of then I placed on the matlab path.

I can make a PS4000Config, but at the
ps4000DeviceObj = icdevice('picotech_ps4000_generic.mdd', '');
command, I get the error that i pasted above.

Best,
Theo

Martyn
Site Admin
Site Admin
Posts: 3469
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Matlab doesnt find picoscope

Post by Martyn » Wed Jul 11, 2018 8:51 pm

You need to be using ps4000a examples and drivers, not ps4000 ones.
Martyn
Technical Support Manager

thedries
User
User
Posts: 4
Joined: Thu May 24, 2018 4:49 pm

Re: Matlab doesnt find picoscope

Post by thedries » Wed Jul 11, 2018 9:09 pm

Great, thanks, this works :)

amit sharma
Newbie
Posts: 1
Joined: Sun Aug 05, 2018 5:26 pm

Re: Matlab doesnt find picoscope

Post by amit sharma » Sun Aug 05, 2018 6:20 pm

I am using 3206D MSO PicoScope. I want to fetch live data from Scope to MATLAB (64 bit). I have installed SDK for the same model (64 bit). i have also added the add-Ons required as mentioned in the video on youtube by PicoTech. when i create Object in Instrument Control Toolbox APP try to connect it, it fails to connect.

Then i have tried the MATLAB code "PS3000A_ID_Block_Example". When i run this code there is an error
Error using instrument/delete (line 82)
Operation failed: An error occurred while executing the driver disconnect code.
Reference to non-existent field 'unitHandle'.
If this error is not an instrument error, use MIDEDIT to inspect the driver.

Error in icdevice (line 311)
delete(obj);

Error in PS3000A_ID_Block_Example (line 54)
ps3000aDeviceObj = icdevice('picotech_ps3000a_generic', 'FV863/0006');

Hitesh
Site Admin
Site Admin
Posts: 2847
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Matlab doesnt find picoscope

Post by Hitesh » Mon Aug 06, 2018 10:32 am

Hi Amit,

This is being handled via your support ticket.

Best wishes,
Hitesh

Software Dev. Engineer

Ase
Newbie
Posts: 1
Joined: Fri Oct 19, 2018 6:32 pm

Re: Matlab doesnt find picoscope

Post by Ase » Fri Oct 19, 2018 6:37 pm

Hi,

i have the same problem as Amit. Is there any solution for this problem?

Thank you

Hitesh
Site Admin
Site Admin
Posts: 2847
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Matlab doesnt find picoscope

Post by Hitesh » Mon Oct 22, 2018 9:18 am

Hi Ase,

If you are having an issue opening a connection using the serial number please try removing the '/' from the serial number e.g. in Amit's case it would be:

Code: Select all

ps3000aDeviceObj = icdevice('picotech_ps3000a_generic', 'FV8630006');
We are aware of an issue in the ps3000a shared library which we hope will be fixed in the near future.

If you are still having an issue, please post a screenshot of the error.

Regards,
Hitesh

Software Dev. Engineer

Post Reply