EEPROM corrupted

Discussion forum for the new Picoscope Linux software
Post Reply
thmslg
Newbie
Posts: 0
Joined: Wed May 02, 2018 10:57 am

EEPROM corrupted

Post by thmslg » Wed May 02, 2018 11:09 am

Hello,

I am facing an issue with my picoscope, and I am not sure how to analyse my issue properly.
My pico (3403DMSO) is not recognized by my graphical tool ("No suitable device found").
I have several picoscopes here (same references), and others are properly recognized by my machine.

When I plug it on my machine, the device is recognized by my system :

Code: Select all

lsusb | grep Pico
Bus 001 Device 005: ID 0ce9:1211 Pico Technology PicoScope 3000 series PC Oscilloscope
But if I parse the
trace.xml
Trace obtained at picoscope tool start in my local folder (~/.local/share/Pico Technology/260a68f1-c314-451b-830f-0a5e01d65514).
(10.96 KiB) Downloaded 136 times
, I find the following :

Code: Select all

<event time="02/05/18 13:03:33.010" category="Device" level="Info">Opening device unsuccessful. Error UnknownDeviceError [EepromCorrupt(10)]</event>
I do not find any mention of this message on google, what can I do ?
Is there a way to reflash the firmware somehow on this model ?

Thanks for your help !
Cheers,
T.

Hitesh
Site Admin
Site Admin
Posts: 2845
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: EEPROM corrupted

Post by Hitesh » Thu May 03, 2018 3:10 pm

Hi T,

Does the device work if it is connected to a PC running a Windows operating system?

If you get the same error, please e-mail support@picotech.com as the device may need to come back here for inspection.

Regards,
Hitesh

Technical Support Engineer

thmslg
Newbie
Posts: 0
Joined: Wed May 02, 2018 10:57 am

Re: EEPROM corrupted

Post by thmslg » Mon May 07, 2018 7:00 am

Same effect on every platform.

We continue with our distributor for guarantee support.

Thanks !
T.

Hitesh
Site Admin
Site Admin
Posts: 2845
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: EEPROM corrupted

Post by Hitesh » Tue May 08, 2018 8:37 am

Hi T.

Thanks - please ask your distributor to reference this thread when they contact us.

Regards,
Hitesh

Technical Support Engineer

Petervg
Newbie
Posts: 0
Joined: Sun Sep 23, 2018 10:25 am

Re: EEPROM corrupted

Post by Petervg » Sun Sep 23, 2018 10:27 am

Hi T,

was this issue resolved? I have an MSO3205D that suddenly has the same problem.

With kind regards
Peter

Martyn
Site Admin
Site Admin
Posts: 3374
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: EEPROM corrupted

Post by Martyn » Sun Sep 23, 2018 11:54 am

Please contact support@picotech.com for assistance, the unit may need to come back for investigation.
Martyn
Technical Support Manager

Petervg
Newbie
Posts: 0
Joined: Sun Sep 23, 2018 10:25 am

Re: EEPROM corrupted

Post by Petervg » Mon Sep 24, 2018 5:49 am

Hi Martyn,

mail is sent with some attachements (screenshots and trace.xml)

With kind regards
Peter

Post Reply