Test and Measurement Forum

HumidiProbe stopped working

Post any questions you may have about our current range of USB data loggers

HumidiProbe stopped working

Postby catusf » Tue Aug 21, 2007 11:38 am

I bought two HimidiProbes recently, and used them for an experiment described below. But they both stopped working after a couple of runs.

Procedure
We want to control the relative humidity of a small cylindrical container (14cm height, 4cm diameter) by saturated salt solutions. In this case potassium iodide and sodium bromide are used. The temperature is kept at a fixed point using a heating tape which is controlled by a PID controller. The heating process from room temperature to required temp of 60oC takes about 5min.

First couple of runs were ok for both of them. But the first probe broke after 5hr in 5th run. The second one broke after 3.5hr in 2nd run. The software showed bad readings such as negative temp and relative humidity.

So have you got any ideas why they stopped working?
Thanks

Dan
catusf
Newbie
 
Posts: 1
Joined: Tue Aug 21, 2007 11:25 am

Postby ziko » Tue Aug 21, 2007 1:17 pm

Hi and thank you for your post. I would suggest you contact us via our support email and return the units to us so we can asses what the problem is at support@picotech.com. From then we can generate a returns number and instructions on how to send the unit back.


Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots


Return to USB PC Data Loggers

Who is online

Users browsing this forum: No registered users and 1 guest