Test and Measurement Forum

LibUsb-Win32 and PicoScope 3205

Post any questions you may have about our current range of oscilloscopes

LibUsb-Win32 and PicoScope 3205

Postby tkumpuma » Wed Aug 15, 2007 11:14 am

Anyone got this scope working with libusb installed on same computer.
I have 2 computers Win2k and XP, both not working when libusb installed.
To get the scope work i needed to completely remove all libusb files.
So is there anyone with working combination?
I need this scope on my laptop and theres also software which uses libusb. :(
tkumpuma
Newbie
 
Posts: 1
Joined: Tue Aug 07, 2007 11:49 am

Postby markB » Tue Aug 21, 2007 7:28 am

I tried installing libusb along side our usb drivers and our drivers still work fine.

I'm not sure how libusb works but could you have associated the pico usb device with the libusb driver? Try re-installing the driver from device manager and ensure you choose the pico driver.
Regards

Mark
markB
Site Admin
Site Admin
 
Posts: 83
Joined: Tue Mar 27, 2007 9:43 am
Location: Cambridgeshire,UK

libusb

Postby geezer » Thu Sep 11, 2008 10:19 am

Hi,

I've installed LibUSB on a system with a working picoscope 3206. After installation my scope stopped working. Everytime I reinstall the driver the scope is recognized, and appears shortly in the device list, but during installation it is removed and does not appear again.
geezer
Newbie
 
Posts: 1
Joined: Thu Sep 11, 2008 10:08 am

Re: LibUsb-Win32 and PicoScope 3205

Postby ee_martin » Wed Jun 23, 2010 3:19 pm

Did anyone find a solution for the libusb-win32 and PicoScope incompatibility?? I think I have the same problem and I can't just de-install libusb as doing development work with that is a major activity for me.

I'm currently using Libusb-win32 version 1.1.14.0 and PicoScope 6.4.28.0 with PicoScope 3205 hardware and the 3205 seems to enumerate, then disconnects itself. Further it totally screws up any chance of connecting new USB equipment and also stops the PC turning off normally.

Any help most gratefully received.

Martin
ee_martin
Newbie
 
Posts: 0
Joined: Tue Mar 02, 2010 6:50 pm

Re: LibUsb-Win32 and PicoScope 3205

Postby johnw » Fri Jun 25, 2010 12:38 pm

I don't know if this is relevant but I read in passing the other
day that some USB devices don't like being on the same hub as others.

It can be a power issue or perhaps a conflict issue I don't know.
Just thought I'd mention it in case.

john
johnw
Newbie
 
Posts: 0
Joined: Tue Mar 16, 2010 9:14 pm
Location: England

Re: LibUsb-Win32 and PicoScope 3205

Postby ee_martin » Fri Jun 25, 2010 1:03 pm

I have the solution, which came from me asking on the libusb site.

I came to the conclusion that the libusb-win32 stuff I have was causing trouble, but I did not know how. I therefore asked on the libusb forum
(https://lists.sourceforge.net/lists/lis ... in32-devel , June 2010, "Libusb incompatibility with PicoScope??") and I got the answer I needed.

libusb-win32 is a package of USB goodies for the PC. It allows me to write my own USB firmware on a microcontroller and interface it to my PC using the libusb drivers. That bit works fine.

However, there is also a libusb "filter". I did not know what that was, but the recommendation was that I should install it, so I did. It turns out that this software attempts to replace all USB drivers for all USB kit. Mostly this works, so if a new USB device that the PC has never seen before is plugged in, this filter software intercepts it and provides libusb as a suitable driver. No need to pre-load CDs, etc.

Unfortunately there are still some bugs in the filter software, and it seems to have tried to use the libusb driver AS WELL AS the PicoScope driver. Confusion then reigned and it all fell over.

The solution is to disable the libusb filter.
[(Start Menu->LibUSB-Win32->Disable Filter (admin only)]

Once I did that, the PicoScope worked fine. Fortunately, my other USB kit works fine too, probably falling back on its own drivers. Some other bug may come out of the woodwork as I start to stress the system, but it all looks good so far.
ee_martin
Newbie
 
Posts: 0
Joined: Tue Mar 02, 2010 6:50 pm


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests