Test and Measurement Forum

PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Discussion forum for the new Picoscope Mac software

PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby ono16 » Sun Apr 08, 2018 5:35 pm

After the most recent security update of OSX, PicoScope won't start. Pls provide a remedy. Thanks.
ono16
Newbie
 
Posts: 0
Joined: Sun Apr 08, 2018 5:27 pm

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby Hitesh » Mon Apr 09, 2018 9:01 am

Hi ono16,

What error messages are you seeing if any? What version of the Mono Runtime is installed?

Are you able to upgrade to the latest version of macOS?

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2714
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby ono16 » Mon Apr 09, 2018 5:41 pm

Hi
No error mesg shows. PS just keeps trying, but MAC says PS not responding and I have to force=quit.

I am unfamiliar with Mono Runtime...PS never asked to install it and MAC shows no file by that name.

I am resisting to change to the latest MAC OS as some s/w (like Camtasia) I use won't run unless I buy a new version.

Thanks.
ono16
Newbie
 
Posts: 0
Joined: Sun Apr 08, 2018 5:27 pm

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby ono16 » Mon Apr 09, 2018 6:57 pm

Hi
I downloaded Mono 5.8.1 and installed, then restarted MAC. Tried PS, but it didn't launch, with MAC saying PS not responding. No error mesg appeared.
BR
ono16
Newbie
 
Posts: 0
Joined: Sun Apr 08, 2018 5:27 pm

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby Hitesh » Tue Apr 10, 2018 11:27 am

Hi ono16,

How long did it take before macOS reported that the software is not responding?

On the first run it can take a few minutes to start (a known issue which will be resolved for the next major release). In the release notes, we do state that the current version has only been tested on macOS Sierra and High Sierra so there is no guarantee of compatibility with El Capitan.

The PicoScope 6 Beta software is reliant on the Mono Runtime to run on Linux and macOS operating systems at this present moment in time.

If you e-mail support@picotech.com, we might be able to make an older version version available to you but there were known issues with this version (some fixes were incorporated into the current version) and you would require Mono Runtime 5.0.1.1.

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2714
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby ono16 » Tue Apr 10, 2018 5:14 pm

Hi
It took 25 sec for MAC to post "PS Not Responding".

I have PicoScope 6.10.1 on a back-up disk, so I moved back to MBP. Tried to run it after Mono installation, but it still asks for Mono (previously, it never asked for Mono). The Mono s/w I installed is 5.0.1 and this is not recognized by PS 6.10.1. (I got this Mono from their archives, uninstalled 5.8.1, installed 5.0.1 and restarted MAC). PS still wants Mono.

Any further suggestions welcome. Thanks.

PS In the meantime, I can run PC version of PS, but this is a bit inconvenient.
ono16
Newbie
 
Posts: 0
Joined: Sun Apr 08, 2018 5:27 pm

Re: PicoScope 6.12.9-4r64 won't run w/ OS10.11.6

Postby Hitesh » Wed Apr 11, 2018 8:52 am

Hi ono16,

Please e-mail support@picotech.com and I will see if I can provide you with a PicoScope 6.11 Beta version to try.

Thanks,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2714
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope for Mac

Who is online

Users browsing this forum: No registered users and 2 guests