Test and Measurement Forum

PicoScope 6.13.2 Beta - Modbus

Forum for discussing PicoScope version 6 (non-automotive version)

PicoScope 6.13.2 Beta - Modbus

Postby P_L » Tue Mar 20, 2018 8:56 pm

Hi!
I tested PicoScope 6.13.2 Beta for Modbus decoding but without success when no parity is configured. After changing to even parity data are sucessfully decored. Is it bug in beta version or error in configuration?

Thank you

Petr
P_L
Newbie
 
Posts: 0
Joined: Tue Mar 20, 2018 8:19 pm

Re: PicoScope 6.13.2 Beta - Modbus

Postby Martyn » Tue Mar 20, 2018 10:03 pm

Can you post a psdata file, it maybe that your data does have even parity.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 3041
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 6.13.2 Beta - Modbus

Postby P_L » Tue Mar 20, 2018 10:22 pm

I am sure the data are no parity. UART decoder shows the data correctly.

there is modbus decoder screenshot
PicoScope_Modbus.jpg
psdata


I am sorry but it is not possible to upload .psdata or zipped version. No file is added to posted attachments.
P_L
Newbie
 
Posts: 0
Joined: Tue Mar 20, 2018 8:19 pm

Re: PicoScope 6.13.2 Beta - Modbus

Postby P_L » Tue Mar 20, 2018 10:27 pm

P_L
Newbie
 
Posts: 0
Joined: Tue Mar 20, 2018 8:19 pm

Re: PicoScope 6.13.2 Beta - Modbus

Postby Martyn » Wed Mar 21, 2018 7:25 am

Modbus RTU requires

Start bit, 8 data bits, Parity Bit, Stop Bit

or

Start bit, 8 data bits, 2 Stop bits

If you set the UART decoder to these settings you get the same data as the Modbus RTU decoder.

Are you sure the data you have is Modbus RTU ? or is it a variation ?
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 3041
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 6.13.2 Beta - Modbus

Postby P_L » Wed Mar 21, 2018 10:30 am

You are right, the problem is in device setup that allows non-standard 8N1 configuration. It's a shame that it's not possible to set it up in the Picoscope. Thank you very much!
P_L
Newbie
 
Posts: 0
Joined: Tue Mar 20, 2018 8:19 pm

Re: PicoScope 6.13.2 Beta - Modbus

Postby Martyn » Wed Mar 21, 2018 11:46 am

If you email support@picotech.com and ask if it is possible to add this as a feature request.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 3041
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests