DC measurement error on 4444

Post any questions you may have about our current range of oscilloscopes
Post Reply
pathammer
Newbie
Posts: 0
Joined: Mon Mar 19, 2018 5:35 pm

DC measurement error on 4444

Post by pathammer » Mon Mar 19, 2018 6:14 pm

Hi there,
I have a PS4444 scope (SN: FS786/0025) and have found significant DC measurement error. My test setup consisted of a BK Precision 4053B Waveform Generator whose output connected to my PS under test and a Keysight 34461A reference DMM.

I double checked the readings with a Fluke handheld multimeter so I know the ref DMM is accurate.

When I apply test DC voltages with the waveform generator, and compare the results from the PS and DMM, I see up to 90 mV difference in the two. The error seems to scale with voltage.
Here is the data I collected:

Code: Select all

voltage(V)    measured error(V)
-9                 0.075
-5                 0.035
-2                 0.00769
-1                -0.00067
1                 -0.0231
2                 -0.0319
5                 -0.06118
9                 -0.0959
I also generated a noise signal with known standard deviation on the waveform generator and the resulting std dev measurement on the PS was correct.

Can you help me address this error? Maybe my PS is not configured correctly?

Gerry
PICO STAFF
PICO STAFF
Posts: 292
Joined: Mon Aug 11, 2014 11:14 am

Re: DC measurement error on 4444

Post by Gerry » Tue Mar 20, 2018 11:13 am

Hi pathammer,

Just to get your expectation right, you can get an error of up to +/- 90.5mV on a measurement of 9V, because that would be within the stated DC accuracy of the PicoScope 4444, according to our specifications, as shown in the image below:
PS 4444 accuracy.png
PS4444 DC accuracy
So, your values are only marginally significant, which can be explained by the offset. From your measurements it looks like all of the positive values are slightly below the -ve DC accuracy limit (so they are slightly out of spec, i.e. greater than -1%), and all of the negative ones are below below the +ve DC accuracy limit (so they are within the spec, i.e. less than +1%). There is enough margin to be able to adjust the offset of the PicoScope (add a small +ve amount to all values) to bring all of the values within the specified accuracy.

Are you using the 'Zero offset' of the 'Channel Options' to set the zero reference point of the PicoScope correctly, before taking your measurements? (see image below):
PS 4444 Zero offset.png
PS4444 Zero offset
If having adjusted the offset the values are still not all within specification and if you are confident of the accuracy of your precision Generator and reference DMM (e.g. they have been calibrated recently enough), then the PicoScope may need recalibration, and you can send an email to support@picotech.com to request that we do this for you.

Regards,

Gerry
Gerry
Technical Specialist

pathammer
Newbie
Posts: 0
Joined: Mon Mar 19, 2018 5:35 pm

Re: DC measurement error on 4444

Post by pathammer » Tue Mar 20, 2018 4:12 pm

Thanks Gerry! Setting the 'Zero offset' for my channel got my error down significantly. Thanks for aligning my expectations with the equipment spec.
Respectfully,
Patrick

pathammer
Newbie
Posts: 0
Joined: Mon Mar 19, 2018 5:35 pm

Re: DC measurement error on 4444

Post by pathammer » Tue Mar 20, 2018 4:16 pm

I forgot to ask, is there a way to set the zero offset programmatically? I couldn't find a function in picoscope-4000-series-a-api-programmers-guide.pdf

Gerry
PICO STAFF
PICO STAFF
Posts: 292
Joined: Mon Aug 11, 2014 11:14 am

Re: DC measurement error on 4444

Post by Gerry » Wed Mar 21, 2018 11:46 am

Hi pathammer,

There is no way to automatically zero the offset without manual intervention (because the scope has no way of knowing what affect the electronics is having on the offset to ground).

However, you can use a similar procedure to the one adopted in PicoScope 6, to zero the offset with manual intervention, i.e.:
  • Request that the user shorts the input channel to ground.
    Get some sample values using ps4000aGetValues() with the downsample mode set to 'PS4000A_RATIO_MODE_AVERAGE' to remove the noise (any non-zero average value returned will be an offset for the block of data).
Then either:
  • Prepare the offset found by converting the ADC count to a voltage.
    Set the 'analogoffset' value in ps4000sSetChannel() using the converted voltage offset (to adjust the electronics).
Or:
  • Store the offset found to add or subtract the value to all collected data (to adjust the conversion).
Note that you would have to repeat this if you are using a different input range (or you could test all input ranges to get the corrections to apply while the input is shorted to ground).

Regards,

Gerry
Gerry
Technical Specialist

nurber
User
User
Posts: 7
Joined: Fri Mar 24, 2017 6:05 pm

Re: DC measurement error on 4444

Post by nurber » Thu Apr 05, 2018 5:26 pm

Hi Forum. I just took delivery of reference device ( DMMCheck Plus ) which is capable of 5VDC & 5VAC (100Hz RMS square wave). On a DMM it seems easy:

1-ensure correct operating temperatures and stabilization of reference device
2-zero/offset for leads to be used for test
3-measure

I understand the accuracy specification of this device and how to calculate, but what is the recommend way to test a 5VDC and 5VAC reference, for example, with a Picoscope 4444? 14-bit, max sampling rate if VAC, but then just measurements for maximum and minimum ? DeepMeasure seems useful for this task ? Perhaps there is a document for such an exercise ? Thank you.

Gerry
PICO STAFF
PICO STAFF
Posts: 292
Joined: Mon Aug 11, 2014 11:14 am

Re: DC measurement error on 4444

Post by Gerry » Mon Apr 09, 2018 11:10 am

Hi nurber,

To check the accuracy of the PicoScope 4444, with your reference, you can do the following.

For DC
1 Select the ±10 V input range (to avoid overranging), use DC coupling and set up the capture for 12-bit, 14-bit or both
2 Let the device settle for 30 mins for stable operating temperature
3 Zero the offset, and set the measurement to DC average
4 Perform the capture

For AC
Same as above except
1 Use AC coupling, 12-bit only and use the Timebase to select your sample rate/bandwidth
3 Measure AC RMS
OR
Same as above (For AC) except
1 Use DC coupling
3 Zero the offset, and measure True RMS
(this will not limit you at the lower end of the bandwidth)

As you are looking for the accuracy of the DC voltage, and the AC RMS voltage, there is no advantage in using Deep Measure (which alllows you to Check individual cycle values) because in both cases you will be performing a type of averaging of the values across the buffer, which the standard measurements will do (and the statistics will tell you all you need to know about the data-set used for the measurement). However, to get a more statistically valid set of results, you could use the full buffer for the measurement, by setting the trigger to single and the number of samples to 300MS.

Regards,

Gerry
Gerry
Technical Specialist

Post Reply