Picoscope 6 Beta 6.12.9.35 won't start without root

Discussion forum for the new Picoscope Linux software
Post Reply
wharvey
Newbie
Posts: 0
Joined: Thu Jun 25, 2015 2:52 am

Picoscope 6 Beta 6.12.9.35 won't start without root

Post by wharvey » Fri Feb 23, 2018 6:57 am

I am running Ubuntu 16.04 (Gnome) with all the latest updates.

I installed the latest Picoscope 6 Beta.
Installation appears to finish without any problems.
When I try to run it, from the GUI or the command line, nothing happens, no messages, no nothing.
If I try to run it from the command line as root, it appears to start up normally,

We originally bought two of these scopes, 5244B, because they were supposed to run under Linux. They have always had stability problems running under linux, and have always been behind in features from the Windows versions.

Hitesh
Site Admin
Site Admin
Posts: 2794
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 6 Beta 6.12.9.35 won't start without root

Post by Hitesh » Mon Feb 26, 2018 9:44 am

Hi wharvey,

Has your standard user account been added to the Pico group? This is required to run the PicoScope application.

We are working towards feature parity between the Microsoft Windows, Linux and macOS platforms, although this will not be until the next major release.

Regards,
Hitesh

Technical Support Engineer

scholtnp
Newbie
Posts: 0
Joined: Sun May 27, 2018 4:58 pm

Re: Picoscope 6 Beta 6.12.9.35 won't start without root

Post by scholtnp » Sun May 27, 2018 5:12 pm

I saw the same problem. Asking the shell if I'm member of the pico group with the following command revealed:

Code: Select all

groups
# peter adm dialout cdrom sudo dip plugdev lpadmin sambashare 
It showed I wasn't. But simply logging out and logging in again solved the problem. Typing groups now reports:

Code: Select all

groups
# peter adm dialout cdrom sudo dip plugdev lpadmin sambashare pico 
Would be handy to have this in the installation instruction of linux (I had to change ownership back from root to myself).

Hitesh
Site Admin
Site Admin
Posts: 2794
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 6 Beta 6.12.9.35 won't start without root

Post by Hitesh » Tue May 29, 2018 1:00 pm

Hi scholtnp,

We are in the process of reviewing the usage of the pico group following feedback so there may well be a change in the future.

Regards,
Hitesh

Technical Support Engineer

Post Reply