Test and Measurement Forum

CAN decoder not decoding when saved with decoded CAN

Forum for discussing PicoScope version 6 (non-automotive version)

CAN decoder not decoding when saved with decoded CAN

Postby bennog » Tue Feb 13, 2018 3:31 pm

I saved a capture file with decoded CAN data.
When opening the file it keeps waiting for CAN data until I switch waveform forward and back or adjust the CAN decoder parameters.

psdata file is here http://www.ans-net.nl/picotech/20180209-0001.decoded.psdata

Benno

CAN-Waiting.png
bennog
Advanced User
Advanced User
 
Posts: 98
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands

Re: CAN decoder not decoding when saved with decoded CAN

Postby Gerry » Thu Feb 15, 2018 12:03 pm

Hi bennog,

I've tried your data file in a PicoScope 4424, PicoScopes at the top and bottom of our range of products, and even in a 2204A (which doesn't have enough buffer space for all of the data) but can't reproduce what you are seeing, as it always loads OK.

Could you post a full screen shot showing all of the PicoScope Screen immediately after opening the data file (before doing anything else) so that we can, for example, see the status of the capture (running or stopped), and explain step by step what you are doing to get to the 'Waiting for data' message.

Regards,

Gerry
Gerry
Technical Specialist
Gerry
PICO STAFF
PICO STAFF
 
Posts: 203
Joined: Mon Aug 11, 2014 11:14 am

Re: CAN decoder not decoding when saved with decoded CAN

Postby bennog » Thu Feb 15, 2018 1:24 pm

It only happens in picoscope 6 beta.
Production version shows the decoded data directly after opening the file.

P.S. there is no scope connected to the PC at the moment of opening the file.

Beta version.
PicoScope® 6 - PC Oscilloscope software version: 6.13.1.3117
Copyright © 1995-2017, Pico Technology Ltd.

2018-02-15 14-22-45.png


Benno
bennog
Advanced User
Advanced User
 
Posts: 98
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands

Re: CAN decoder not decoding when saved with decoded CAN

Postby Gerry » Mon Feb 19, 2018 6:12 pm

Hi bennog,

What version of the Beta are you running? I can't get it to 'wait for data' in version 6.13.2.3439 (with or without a scope attached).

Have you tried a different computer (in case there is a resource issue)?

Regards,

Gerry
Gerry
Technical Specialist
Gerry
PICO STAFF
PICO STAFF
 
Posts: 203
Joined: Mon Aug 11, 2014 11:14 am

Re: CAN decoder not decoding when saved with decoded CAN

Postby bennog » Mon Feb 19, 2018 6:24 pm

Your beta is newer 8)

PicoScope® 6 - PC Oscilloscope software version: 6.13.1.3117
Copyright © 1995-2017, Pico Technology Ltd.

Info was also in previous post.

O and for me there is no update :D , no problem because it is simple to fix.

Regards,
Benno
bennog
Advanced User
Advanced User
 
Posts: 98
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands

Re: CAN decoder not decoding when saved with decoded CAN

Postby Martyn » Tue Feb 20, 2018 6:51 am

The version on the Downloads Page is PicoScope 6.13.2

Did your version not pick up that there was a new release ? if you have the option set.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 3013
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: CAN decoder not decoding when saved with decoded CAN

Postby bennog » Tue Feb 20, 2018 8:59 am

It did not pick up the new beta release.
Option was set to message when there was a update.
Even manual test for update did not work, installed latest beta yesterday manually.

Problem is solved now, thanks for the support.

Benno
bennog
Advanced User
Advanced User
 
Posts: 98
Joined: Mon Nov 26, 2012 9:16 am
Location: Netherlands


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests