Test and Measurement Forum

Picoscope 3204D USB 3 crashes while USB 2 works

Having problems ? let us know the details here

Picoscope 3204D USB 3 crashes while USB 2 works

Postby flonix » Wed Jan 24, 2018 7:39 pm

Hello,

I just got a brand new 3204D MSO scope. When connecting it with the included USB 3 cable to my Dell Latitude 7480, it gets listed in the Windows device manager under "Pico Technologies". However, when I start the PicoScope 6 Software, it doesn't get enumerated. Even more, it disappears from the device manager.

Using a cheap third party USB 2 cable works, but when starting up, PicoScope Software gives me the screen asking me for whether the power-supply through USB is enough. I check "use USB power" and (with a somewhat bad conscience), I click ok. The device gets enumerated and I can do measurements but leaving me with the bad feeling, that the power might not be enough.

How can I determine whether my USB 3 port has enough power? (I couldn't find any specs about the power consumption of the scope)
If the power is not enough, is there still a possibility to connect via USB 3? (e.g. could you propose a USB 3 hub or are the USB 3 y-cables? Please advise on a suitable USB hub anyway as I will run short on ports soon)
Or is falling back to your y-cable (TA146) the right thing to do? (I will also use the scope with my Macbook Pro which only has USB 2 ports - and currently shows the same message-box asking for enough power, but immediately brakes during data acquisition)

Thanks for your help!
Florian
flonix
User
User
 
Posts: 2
Joined: Wed Jan 24, 2018 7:24 pm

Re: Picoscope 3204D USB 3 crashes while USB 2 works

Postby Hitesh » Thu Jan 25, 2018 10:17 am

Hi Florian,

Are you using a USB 3.1 port with PowerShare enabled on it?

Are your USB 3.1 chipset drivers up to date?

Was the third-party USB 2.0 cable that you used connected to the USB 3.1 port on the laptop?

It might be useful to see the trace.xml file from when you try to start the PicoScope 6 software on a Windows operating system with the device connected on a USB 3.1 port. Please refer to section 3 of our PicoScope FAQ for instructions on where to locate this.

We do recommend the use of our USB cables as they designed to have connection from the shielding to the ground pin at the PC end. Do you require the USB 3.0 capability of the device in terms of data transfer?

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2577
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Picoscope 3204D USB 3 crashes while USB 2 works

Postby flonix » Thu Jan 25, 2018 5:19 pm

Hello Hitesh,

thanks for the timely answer. To not get confused, let's first only focus on connecting with Dell / Windows 10 Laptop via USB 3.0 / powersharing.

I have enabled the powersharing feature through my bios according to the Dell website. This feature was disabled before. However, I still see the same behaviour: the scope appears in the device manager under "Pico Technology Instruments" and disappears when starting PicoScope 6 Software.

I have located the trace.xml file (see attached). It was empty after the first attempt, but it shows data after the second attempt.

In windows, I can see that I have the most current "Intel(R) USB 3.0 eXtensible-Hostcontroller - 1.0 (Microsoft)" - trying to update the driver via Windows results in a message that my driver is the most current one.

Cheers
Florian
flonix
User
User
 
Posts: 2
Joined: Wed Jan 24, 2018 7:24 pm

Re: Picoscope 3204D USB 3 crashes while USB 2 works

Postby Martyn » Fri Jan 26, 2018 8:02 am

flonix wrote:I have located the trace.xml file (see attached). It was empty after the first attempt, but it shows data after the second attempt.

The attachment is missing, if you are having problems posting it please email support@picotech.com and we can take a look there.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2908
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests