Test and Measurement Forum

Scopes not detected as serial devices

Discussion forum for the new Picoscope Linux software

Scopes not detected as serial devices

Postby tei » Thu Nov 16, 2017 3:37 pm

We have two equivalent PicoScope 6402C on two different Ubuntu 14.04 (4.4.0-98-generic). Since yesterday (no obvious changes on the systems) the Picoscope are not detected as serial devices any more. Nevertheless the Picoscope are definitely connected since a "lsusb" shows: "Bus 002 Device 010: ID 0ce9:1204 Pico Technology PicoScope 6000 series PC Oscilloscope" and your Picoscope-Software finds the device. But no ttyUSBX is shown and the libcalls to the devices are failing. We call the devices with phyton and Matlab and the same exact error is: "Warning: Disconnect: No devices found. " The scripts are running for more than one year, so its somehow a hardware communication problem. We are searching for hours now but we are stuck.

dmesg outputs the following but no mapping from ftdi is taking place:
[ 1356.157942] usb 2-1.5: USB disconnect, device number 10
[ 1412.944309] usb 2-1.5: new high-speed USB device number 11 using ehci-pci
[ 1413.037404] usb 2-1.5: New USB device found, idVendor=0ce9, idProduct=1204
[ 1413.037409] usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1413.037412] usb 2-1.5: Product: WestBridge
[ 1413.037415] usb 2-1.5: Manufacturer: Cypress
[ 1413.037417] usb 2-1.5: SerialNumber: ************

Did something likely occurred to you or do you have any hint where we have to look for the error?
tei
Newbie
 
Posts: 0
Joined: Fri Jun 17, 2016 8:06 am

Re: Scopes not detected as serial devices

Postby Hitesh » Fri Nov 17, 2017 9:54 am

Hello tei,

Please try running the usbtest application from the following folder:

/opt/picoscope/share/docs/libps6000

Are you able to verify connectivity on a PC with a Microsoft Windows operating system?

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2515
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests