Test and Measurement Forum

ADC 11 much slower than Dr-DAQ in Lab View, Driver Problem?

Post general discussions on using our drivers to write your own software here

ADC 11 much slower than Dr-DAQ in Lab View, Driver Problem?

Postby Guest » Wed May 21, 2003 12:31 pm

When I changed my Dr-Daq card and drivers for ADC-11, my labview
application became much slower. Could this problem related to "Single reads of ADC11 too slow in Labview. If so where can I find old drivers for the old ADC11 card?

Technical information:
OS : NT4
LV 6.1
Old and slow PC
New ADC 11 card (bought two months ago)

All help appreciated,

Hugo
Guest
 

Postby markspencer » Thu May 22, 2003 10:06 am

Hi,

The sampling rate for he ADC11 is 10ksps, however this is divided up between the active channels.

The driver for the ADC-11 should not effect the speed of the application. If you require a faster sampling rate than you are getting from calling adc11_get_value() (approx 200µs to take one reading), The response to the call is effected by the PC's clock and other processes that are running, use the function adc11_get_values(), which will return a block of samples in a set sampling interval.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am

Postby Guest » Thu May 22, 2003 12:05 pm

Tanks for the answer,

I think that my problem is located in a different region, whit the Dr-Daq drivers (and card) (using DrDaq singel.vi), I could take 10 measurements in one second and use only a small fraction of the PC’s CPU time. For a single measurement (one channel) with the ADC11 (12bits) card I need 100 % of the computers CPU time (using ADC11 singel.vi). All other parts of the program remained the same.
I read “Single reads of ADC11 too slow in Labview” from Chris Dancer on your newsgroup. Is it possible that the two problems are related. Is it possible to get and use the old drivers for the ADC11 (are they compatible whit new cards and NT4).

Regards

Hugo
Guest
 

Postby markspencer » Fri May 23, 2003 7:29 am

Hi Hugo,

The labview application will use all the processor time that it is given. If the OS (NT4) allows it to use 100% of the processor then it will do this.

I will speak to the relevant department with regards to this problem. You can get the old driver off the CD which was sent with the ADC-11/12.

Best regards,
Regards,

Mark Spencer
User avatar
markspencer
Site Admin
Site Admin
 
Posts: 598
Joined: Wed May 07, 2003 9:45 am


Return to General Software Discussions

Who is online

Users browsing this forum: No registered users and 0 guests