Test and Measurement Forum

ps5000a.dll and 64bit Labview EXE application

Post your LabVIEW discussions here

ps5000a.dll and 64bit Labview EXE application

Postby qas » Thu Jul 06, 2017 10:57 am

Hi!

Some issue with ps5000a driver. Win10 64bit system, Labview 64bit, and Pico SDK 64bit.

For example:

1) Simple project with ps5000 (not ps5000a !):

Image

2) Library call config:

Image

3) When I click Run everithing is OK.

4) Let's build EXE application:

Image

(data folder contains ps5000.dll file)

5) And run it:

Image

No errors.

6) Same things with ps5000a driver:

Image

No errors and Labview can run it.

7) Library config:

Image

8) Build the application:

Image

(now data folder contains ps5000a.dll file)

9) ... and run it:

Image

So I have no idea what is wrong. Labview EXE can't find any function from ps5000a.dll.
qas
Newbie
 
Posts: 0
Joined: Thu Jul 06, 2017 9:54 am

Re: ps5000a.dll and 64bit Labview EXE application

Postby Hitesh » Fri Jul 07, 2017 9:09 am

Hi qas,

Have you tried adding the picoipp.dll to the project as a dependency?

It might be worth trying the ps5000aOpenUnit() function as well. There are sub-vi files in the PicoScope5000a.llb file which is available as a 32-bit version via our GitHub repository.

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2495
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: ps5000a.dll and 64bit Labview EXE application

Postby qas » Fri Jul 07, 2017 10:38 am

Thanks, Hitesh.

Hitesh wrote:Have you tried adding the picoipp.dll to the project as a dependency?

I'm sorry, I don't know how to do that. I try to copy picoipp.dll to the application "data" folder and that has no effect.

Hitesh wrote:It might be worth trying the ps5000aOpenUnit() function as well. There are sub-vi files in the PicoScope5000a.llb file which is available as a 32-bit version via our GitHub repository.


In my current project I use several functions from ps5000a.dll (including ps5000aOpenUnit function), and it perfectly works in the Labview environment, but when I build EXE application and run it at the same PC, it doesn't work.

Image

I can't run ps5000a 32bit examples from repository, because I don't have 32bit Labview at the moment,
but I check out 64bit examples to ps5000 driver and it works fine as EXE application, without "missing external function" errors.
qas
Newbie
 
Posts: 0
Joined: Thu Jul 06, 2017 9:54 am

Re: ps5000a.dll and 64bit Labview EXE application

Postby Hitesh » Wed Jul 12, 2017 9:06 am

Hi qas,

We have just released a new PicoSDK driver package installer - could you please try installing this?

How did you add the ps5000a.dll as a dependency to the project? That would be the way to add the picoipp.dll file.

The alternative is to place the 64-bit ps5000a and picoipp dll files in the same directory as your executable and see if they are detected.

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2495
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: ps5000a.dll and 64bit Labview EXE application

Postby qas » Thu Jul 13, 2017 10:36 am

Hitesh wrote:We have just released a new PicoSDK driver package installer - could you please try installing this?


New PicoSDK solves the problem. Thank you.
qas
Newbie
 
Posts: 0
Joined: Thu Jul 06, 2017 9:54 am

Re: ps5000a.dll and 64bit Labview EXE application

Postby Hitesh » Fri Jul 14, 2017 9:05 am

Hi qas,

Good to hear that has resolved the issue :)

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2495
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to LabVIEW

Who is online

Users browsing this forum: No registered users and 0 guests