Test and Measurement Forum

Bandpass function appears to not work ...

Forum for discussing PicoScope version 6 (non-automotive version)

Bandpass function appears to not work ...

Postby evalon » Mon Jun 26, 2017 7:09 am

Hi Picoscope forum,

I have a probably quite simple "challenge" that I hope one of you may be able to help with.

As it is I have a PS3206MSO and am trying to set up a bandpass filter. To this end I have clicked the bandpass option in the math dialog box, yet even if I enter a frequency range that should be within the 1/64000 minimum relative to the sample rate - and use the syntax described in the user's guide - it appears that there is an error (software is version 6.12.7.2687; Win7).

I've attached a screendump of what the error looks like. I am not allowed to click next and the red "X" sign indicates some kind of error ... ?

I'd appreciate your help in this :wink:

Cheers,

Jesper M.
Attachments
picoscope.jpg
evalon
Newbie
 
Posts: 0
Joined: Mon Jun 26, 2017 6:47 am

Re: Bandpass function appears to not work ...

Postby Martyn » Mon Jun 26, 2017 8:05 am

Can you check this with the version 6.12.9 which was released on Friday. Some work has been done in this area and your settings appear to work for me.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2781
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Bandpass function appears to not work ...

Postby evalon » Mon Jun 26, 2017 9:26 am

Hi Martyn,

& thanks for your prompt reply. I've tried to install the software version you linked to but unfortunately no difference ... Any ideas?

Cheers,

Jesper
evalon
Newbie
 
Posts: 0
Joined: Mon Jun 26, 2017 6:47 am

Re: Bandpass function appears to not work ...

Postby Martyn » Mon Jun 26, 2017 9:57 am

Can you post a psdata file, I will then open it and check if I can enable a Bandpass filter with your settings. If I read your screen capture correctly is

BandPass(A,10000,200000)

which gets translated to

BandPass(A; 10000; 200000)
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2781
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests