Test and Measurement Forum

Glitch in 2205A AWG triangle...

Post any questions you may have about our current range of oscilloscopes

Glitch in 2205A AWG triangle...

Postby alank2 » Sat Jun 24, 2017 12:28 am

I noticed that there is a glitch when looking at a triangle wave on a 2205A:

See this picture:

http://home.earthlink.net/~alank2/2205a.png

In this case it is happening at zero. I confirmed this by looking at it on an analog scope as well. My 2207B AWG does NOT do this.

Any ideas?
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby Martyn » Mon Jun 26, 2017 8:25 am

Can you post the psdata file, we can then look at all the settings as well as the data.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2687
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Mon Jun 26, 2017 1:20 pm

I can get this tonight, but there is nothing special about it. Turn on the AWG, select triangle, I think it was 800mV amplitude. The issue was viewed on an analog scope and also a 2207B. Can you try to repeat this test with a 2205A to see if you can reproduce it?
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby Martyn » Mon Jun 26, 2017 1:42 pm

I am not seeing the same effect here using the current release 6.12.9, so the psdata file would be useful, just to make sure that we are set up in an identical manner.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2687
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Mon Jun 26, 2017 1:53 pm

Will test tonight with this version, didn't know a new one was out. Is there a change log or what's new for this version?
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Mon Jun 26, 2017 2:10 pm

Also, it doesn't see the glitch itself easily, so connect the output of the 2205A to a higher bandwidth/different clock domain scope to see if you can reproduce it.
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby Martyn » Wed Jun 28, 2017 9:12 am

I am not seeing a glitch when connecting to other higher spec scopes, but it may be settings related so a psdata file would be useful.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2687
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Thu Jun 29, 2017 12:57 am

Still does it with 6.12.9 as well... settings file enclosed.
Attachments
crossoverdistortion.pssettings
(3.04 KiB) Downloaded 7 times
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby Martyn » Mon Jul 03, 2017 1:38 pm

With your settings I am seeing the glitch, it is related to the signal generator voltage level, and becomes more visible the lower the level gets. I will raise this as an issue with the development team.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2687
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Mon Jul 03, 2017 2:48 pm

I'm glad it can be reproduced at least. Let me know if you can when it might be fixed and I'll test it.
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby alank2 » Wed Aug 09, 2017 2:16 pm

Any update from development yet?
alank2
User
User
 
Posts: 3
Joined: Wed Nov 16, 2016 7:21 pm

Re: Glitch in 2205A AWG triangle...

Postby Martyn » Mon Aug 21, 2017 1:29 pm

I have not received an answer yet so I have requested an update.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2687
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to USB PC Oscilloscopes

Who is online

Users browsing this forum: No registered users and 0 guests