Gentoo Installation

Post your Linux discussions here
Post Reply
Posts: 0
Joined: Fri Jun 02, 2017 12:14 am

Gentoo Installation

Post by bmckee »

I found an old thread on here for Gentoo Installation from 2015 but I'm having a different problem.

I have tried both a gentoo mono install and the picotech compiled mono and they both have the same problem:

Code: Select all

Info: Trace opened 6/1/2017.
Environment: Info: Running on Mono - True
Environment: Info: Mono Display Name - 4.4.1 (Nightly Thu Jun  1 15:18:09 PDT 2017)
Environment: Info: Host Operating System - Linux
Environment: Info: 64Bit Operating System - True
Environment: Info: 64Bit Process - True
Environment: Info: Logical Processors - 8
ApplicationInfo: Info: Application 'PicoScope 6 Beta' (version starting.
ID: Info: 1A6CA24957E64CFFB95B4BF5B60D7CC6
Environment: Info: User is not Guest
Environment: Info: No Administrator Privileges
Environment: Info: Failed to detect access rights
Environment: Info: OS Version - Unix
Environment: Info: .net Version - 4.0.30319.42000
Environment: Info: Current Directory - /opt/picoscope/lib
Environment: Info: Command Line - /opt/picoscope/lib/PicoScope.GTK.exe
ApplicationInfo: Info: Settings file version - 11.2.0
ApplicationInfo: Info: Preferences file version - 2.0.0
ApplicationInfo: Info: Probes file version - 1.0.0
ApplicationInfo: Info: Data file binary header version - 1
Error: Creating Preferences file.
Info: Using default culture: English (United States).
InitalDeviceLoadSequence: Info: Begin
Scanning for USB devices: Info: Begin
Scanning for USB devices: Info: Complete
Device: Info: Attempting to load ps6000.dll
Device: Info: Finished loading ps6000.dll
Device: Info: Opening device using DLL ps6000.dll cannot open shared object file: No such file or directoryStacktrace:

Native stacktrace:

        /usr/bin/mono() [0x4ad5cf]
        /usr/bin/mono() [0x50286e]
        /usr/bin/mono() [0x428463]
        /lib64/ [0x7f4eca551f30]
        /lib64/ [0x7f4ecae791e1]
        /lib64/ [0x7f4ecae73314]
        /lib64/ [0x7f4eca75e499]
        /lib64/ [0x7f4eca75dfdf]
        /opt/picoscope/lib/ [0x7f4eaf0bb4a9]
        /opt/picoscope/lib/ [0x7f4eaf0b83d5]
        /opt/picoscope/lib/ [0x7f4eaf0b9859]
        /opt/picoscope/lib/ [0x7f4eaf07af55]

Debug info from gdb:

warning: File "/usr/bin/" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
        add-auto-load-safe-path /usr/bin/
line to your configuration file "/home/brian.mckee/.gdbinit".
To completely disable this security protection add
        set auto-load safe-path /
line to your configuration file "/home/brian.mckee/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
        info "(gdb)Auto-loading safe path"
The file mono is looking for is actually installed in the correct directory (the same place that the ps6000 driver is loading from). But for some reason the code can't find it.

I've tried exporting LD_LIBRARY_PATH:

Code: Select all

export LD_LIBRARY_PATH="/opt/picoscope/lib:$LD_LIBRARY_PATH"
I'd appreciate any help anyone can offer. I really don't want to run picoscope in a windows 10 virtual machine.


Update: I needed to run ldconfig as root and the software started working, but I'm getting glib warnings which are slowing everything down.

Code: Select all

(PicoScope.GTK:6077): GLib-CRITICAL **: Source ID 3857 was not found when attempting to remove it
I'll google that next.

Advanced User
Advanced User
Posts: 2856
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Gentoo Installation

Post by Hitesh »

Hi bmckee,

Could you please post the result of the ls command on the /opt/picoscope/lib folder?

Did you follow all the steps from our webpage in order to configure the package manager and install PicoScope Beta for Linux?


Software Dev. Engineer

Post Reply