Test and Measurement Forum

PicoScope 6.12.7.2687 bugs and issues

Having problems ? let us know the details here

PicoScope 6.12.7.2687 bugs and issues

Postby checio » Thu Apr 20, 2017 10:05 pm

Hi Everybody,
This topic is intended to report an bugs / errors in newest software.

Issue: changing time base causes application crash
Hardware: Pico 5244B
Config: collection time units: "times per division"
Description: during normal job, from time to time I have to change timebase. Every 10-20 attempts, altering this (either by arrows or selecting from popup menu) causes application to close as it would be done by Alt-F4; I mean, I got message "application error" (or something like that) and app starts to shut down with message "saving lastsession". Then Picoscope relunches by itself. Settings are propelly restored (even just selected new timebase). Sometimes it want to send crash report but cannot connect to server.
Part of trace.xml:
    CollectionTimeCombo changed to 5 ms/div</event>
    <event time="18-03-17 22:31:39.262" level="Info">Trigger set to : NonAdvancedEdge</event>
    <event time="18-03-17 22:31:39.370" level="Info">Trigger set to : NonAdvancedEdge</event>
    <event time="18-03-17 22:31:44.493" level="Info">LiveTrigger drag start</event>
    <event time="18-03-17 22:31:48.452" level="Info">Trigger set to : NonAdvancedEdge</event>
    <event time="18-03-17 22:31:48.455" level="Info">LiveTrigger moved to PreTrig 9,964992 : Threshold 0 V</event>
    <event time="18-03-17 22:31:48.591" level="Error">Exception caught in Threadpool Task 'CBE RequestData'</event>
    <event time="18-03-17 22:31:48.634" category="Exception" level="Error">Unhandled Exception:System.ObjectDisposedException: Cannot access a disposed object.
Part of another trace.xml:
    CollectionTimeCombo changed to 5 ms/div</event>
    <event time="19-03-17 00:43:56.512" level="Info">Trigger set to : NonAdvancedEdge</event>
    <event time="19-03-17 00:43:57.256" category="Interaction" level="Info">Unregistered (_buttonPrevious) Button.Click</event>
    <event time="19-03-17 00:43:57.260" category="UI" level="Info">CollectionTimeCombo changed to 2 ms/div</event>
    <event time="19-03-17 00:43:57.338" level="Info">Trigger set to : NonAdvancedEdge</event>
    <event time="19-03-17 00:43:57.542" level="Error">Exception caught in Threadpool Task 'CBE RequestData'</event>
    <event time="19-03-17 00:43:57.578" category="Exception" level="Error">Unhandled Exception:System.ObjectDisposedException: Cannot access a disposed object.
It may have something common with "preferences" and setting "collection time units". I noticed unexpected changes to scope grid in time axis from times_per_division to total_time. Preferences remains unchanged.

This issue was also in previous PicoScope relases: 6beta (6.12.3.2410) and previous 6 (unknown ver)
I may sent full reports from Pico 6beta to e-mail adress.
checio
User
User
 
Posts: 3
Joined: Thu Apr 20, 2017 9:12 pm

Re: PicoScope 6.12.7.2687 bugs and issues

Postby Hitesh » Tue Apr 25, 2017 8:53 am

Hi checio,

I will respond via your e-mail support ticket.

Thanks,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2386
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests