Test and Measurement Forum

cant find 'RunBlock' in DLL 'ps2000aWrap.dll'.”

Post your .Net discussions here

cant find 'RunBlock' in DLL 'ps2000aWrap.dll'.”

Postby BenLarge » Thu Apr 06, 2017 2:32 pm

Hi,
I've recently started using this program/software and I'm trying to run the PS2000aVBDotNetExample under visual studio.
when I run the programme in debug mode I receive the run time error “Unable to find an entry point named 'RunBlock' in DLL 'ps2000aWrap.dll'.” after it prompts me to connect channel A and press enter.

I have the dll's in “C:Program Files\ (x86)\Pico Technology\SDK\lib” and it seems not to have a problem finding the others. as I've looked through the code and one of the dll's is used to open the function ps2000aOpenUnit.

I was wondering if anyone has come across this problem and solved it or if they've got any suggestions on how to maybe solve it.
BenLarge
Newbie
 
Posts: 0
Joined: Thu Apr 06, 2017 2:02 pm

Re: cant find 'RunBlock' in DLL 'ps2000aWrap.dll'.”

Postby Hitesh » Thu Apr 06, 2017 3:13 pm

Hi Ben,

Do you have the Microsoft Visual C++ 2010 Redistributable Package (x86) installed?

If it is not present in the Windows Programs and Features window, please install this as the wrapper has a dependency on it.

Edit: I've sent you a link to a modified example that does not use the wrapper.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2284
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire


Return to .Net Languages (C#, VB.Net, .)

Who is online

Users browsing this forum: No registered users and 0 guests