x10 Scope Probe and Math Channel Discontinuity

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
darrengould
Newbie
Posts: 0
Joined: Thu Mar 23, 2017 3:18 pm

x10 Scope Probe and Math Channel Discontinuity

Post by darrengould » Thu Mar 23, 2017 3:52 pm

Hi there,

I'm see an unexplained discontinuity using a x10 probe, Picoscope 6403C and the latest Picoscope 6 software. The signal in question is a simple sine wave, maximum voltage 180Vpp, 32kHz and I'd like to calculate the power using a math channel set to C*C.

The math channel C*C looks fine when the probe is set to x1, ie no scaling factor on the input voltage, see picture below.
Math channel x1.png
Math Channel with x1 Probe Setting


However, when I set the probe to x10, the waveform C*C changes to that shown below.
Math channel x10.png
Math Channel with x10 Probe Setting


I'm thinking this is a software glitch (unless I'm missing something, in which case please correct me :)) and I'd like a workaround. Any ideas?

Thanks,
Darren

Martyn
Site Admin
Site Admin
Posts: 3225
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: x10 Scope Probe and Math Channel Discontinuity

Post by Martyn » Thu Mar 23, 2017 9:10 pm

Can you go into the maths channel dialogue, edit and manually set the range, or post a psdata file for one waveform and I can take a look when I am in the office tomorrow.
Martyn
Technical Support Manager

darrengould
Newbie
Posts: 0
Joined: Thu Mar 23, 2017 3:18 pm

Re: x10 Scope Probe and Math Channel Discontinuity

Post by darrengould » Fri Mar 24, 2017 2:28 pm

Hi there,

I did try to manually change the axis limits but it didn't help. Notice as well that the value shown in the picture is also wrong. The C waveform is about ~50Vp which means C*C must be 0-~2.5kVp but with the x10 probe, the math channel is set to +/-10kV and the C*C waveform is much larger.

Darren

darrengould
Newbie
Posts: 0
Joined: Thu Mar 23, 2017 3:18 pm

Re: x10 Scope Probe and Math Channel Discontinuity

Post by darrengould » Tue Mar 28, 2017 1:36 pm

Hi Martyn,

Any word on this issue?

Darren

Martyn
Site Admin
Site Admin
Posts: 3225
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: x10 Scope Probe and Math Channel Discontinuity

Post by Martyn » Mon Apr 03, 2017 9:20 am

A psdata file would be helpful, I need to play around with a few settings.
Martyn
Technical Support Manager

Post Reply