Test and Measurement Forum

SOLVED: PicoScope 6, 2204A, "No suitable device found"

Forum for discussing PicoScope version 6 (non-automotive version)

SOLVED: PicoScope 6, 2204A, "No suitable device found"

Postby KBB » Wed Dec 07, 2016 3:04 pm

Hi,

I am one of several engineers working in a medium-sized company, located in Denmark.
We use a dozen or so 2204 PicoScopes for various purposes, and have had no problems with these, now discontinued, oscilloscopes. I recently bought the new version, 2204A (*DV943/182*), and cannot get it to work.

Windows 7 finds the device after I connect it, and loads a driver (PicoScope 2000 series PC Oscilloscope, 2.0.4.0, 23-07-2014).
When I start PicoScope 6 (6.11.12.1692), I hear the characteristic "click" as the device is opened.
I then get the message "No suitable device found".

If I reconnect the device, PicoScope 6 shows "Opening devices..." and is stuck there.

I tested this on several other computers often working with the 2204, and I got the same result.
After reading several posts on this forum, from people who seem to have the same issue, I tried installing the beta (6.12.3.2410), as well as the SDK (PicoSDK 10.6.10 (64-bit)) to no avail.

Please advise me how I might get this to work for now, and when you expect to have this fixed.
If I can assist you with troubleshooting, please let me know.

Kind regards,
Kent B.
Innoscan A/S
http://innoscan.dk/
Last edited by KBB on Fri Dec 09, 2016 6:21 pm, edited 1 time in total.
KBB
Newbie
 
Posts: 0
Joined: Wed Dec 07, 2016 2:04 pm

Re: PicoScope 6, 2204A, "No suitable device found"

Postby KBB » Fri Dec 09, 2016 6:04 pm

Hi again,

I figured out what the problem was, and it is now solved. Maybe this information can help someone.
TL;DR: I solved the problem by using the original blue USB-cable.

I connected the 2204A, and opened PicoScope 6.
Inside the trace.xml file, found in "C:\Users\XXX\AppData\Local\Pico Technology\64XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX", I noticed the following lines:
Code: Select all
...
<event time="09-12-16 18:54:13.508" category="Scanning for USB devices" level="Info">Begin</event>
...
<event time="09-12-16 18:54:14.124" category="Scanning for USB devices" level="Info">Found device 0CE9_1007</event>
<event time="09-12-16 18:54:14.124" category="Scanning for USB devices" level="Info">Complete</event>
<event time="09-12-16 18:54:14.139" category="Device" level="Info">Attempting to load ps2000.dll</event>
<event time="09-12-16 18:54:14.163" level="Info">ModuleInitPass Hs</event>
<event time="09-12-16 18:54:14.163" category="Device" level="Info">Finished loading ps2000.dll</event>
<event time="09-12-16 18:54:14.163" category="Device" level="Info">Opening device using DLL ps2000.dll</event>
...
<event time="09-12-16 18:54:16.930" level="Error">HW error occurred: 5. Requires HW reboot.</event>
<event time="09-12-16 18:54:16.931" category="Device" level="Info">Opening device unsuccessful. Error NotResponding</event>
<event time="09-12-16 18:54:16.932" category="Device" level="Info">No of Devices Found: 0</event>
...

After that, I connected the 2204 to compare, but to my surprise, that resulted in the same error. After I replaced the cable, both devices worked. It turns out that a standard thin 3m usb cable, does not work with either device. There was no noticeable damage on the cable.
KBB
Newbie
 
Posts: 0
Joined: Wed Dec 07, 2016 2:04 pm

Re: SOLVED: PicoScope 6, 2204A, "No suitable device found"

Postby Martyn » Mon Dec 12, 2016 8:40 am

Good to hear it's working :)

Our cables have thicker cores to provide the necessary power required by the devices, so other cables can cause this type of issue.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2779
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 1 guest