Test and Measurement Forum

ADC-212 Not Found

Having problems ? let us know the details here

ADC-212 Not Found

Postby SteveT » Sat Aug 05, 2006 4:25 pm

I've just bought a new PC, and it does not have a parallel port on it, so I asked for one to be fitted, as I have various equipment that requires such a port.

The port works fine with my JTAG equipment, and other development boards, but it doesn't seem to work at all with Picoscope. When plugged in a powered up the red light comes on, but when the software is loaded, it just says "ADC-212 Not found" and the light does not extinguish.

The parallel port shows up as LPT3 and is identified in device manager as "NetMos PCI ECP Parallel Port", and I have selected this in the Picoscope software. There is no LPT1 or LPT2 in device manager. There are no settings to change for the device in the device manager apart from the usual (Disable/Enable, Interrupt allocation, Enable legacy plug and play detection, and driver update).

Any advice would be appreciated!
SteveT
 

Postby Sarah » Tue Aug 08, 2006 1:59 pm

Hi

Thank you for your post.

Is the parallel port only an ECP one? Can it be set to other modes? The ECP mode is not optimal for our devices and on some computers it doesn't work.

If the light is not going out this means that it hasn't connected with the device at all. Try selecting the other LPT port numbers in File, Setup, Converter to see if these make a difference. Windows can virualise the port so it might go by a different number in some cases.

If none of this helps then I think the best thing to do is to use one of our USB to Parallel adaptors as this will circumvent all of these issues.

Best Regards
Sarah
 

Parallel port problems

Postby pr242 » Mon Sep 18, 2006 10:20 am

Hi,

I have the same problem with an ADC200 - connects fine to my laptop, but will not connect with my new pc (dual core AMD). I have tried *all* parallel port modes.

The port on the new pc works fine with other equipment.

I have noticed that this seems to be quite a common problem, and the response is always 'get the usb adaptor'.

Perhaps it would be more usefull if you guys took another look at your parallel port driver ?

Cheers
pr242
Newbie
 
Posts: 1
Joined: Mon Sep 18, 2006 10:00 am

same issues

Postby CSN » Wed Dec 13, 2006 3:23 pm

I have exactly the same problem, I have tried pretty much everything I can think of to get my ADC-212 working with the common NetMos PCI ECP Parallel Port but it doesn't want to play at all. The ADC-212 worked fine on my old P.C with some integrated parallel port. So I simply fitted a new PCI port to my new P.C thinking it would just work. I now have the additional expense of purchasing a converter on top of the new P.C and now redundant PCI Parallel port.

If anyone can suggest anything else, it would be most appreciated.

Cheers

Craig
CSN
 

Postby alan » Mon Feb 26, 2007 7:00 pm

Hi,

If you have not already done so, try going into the PCs BIOS (you usually have to hit F10 or escape etc when the computer first starts up, if it goes into Windows its too late).

In the BIOS there is usually a section called integrated hardware or similar. Somewhere there will be the settings for the parallel port. Make sure these are set to output only, standard or SPP.

If this does not work, it is on occasion worth selecting LPT3 as above within our software. If in the past you have installed other software for parallel port deivces other than printers (eg scanners, zip drives, eprom programmers) then its possible that the driver software for these devices is grabbing control of the port before we can. If this may be the case then try uninstalling this software to see if it helps. Other than that the usual cause is a faulty parallel port, faulty cable or faulty product so it makes sense to try the scope on another PC.

Regards
Alan

Regards
Alan
alan
Site Admin
Site Admin
 
Posts: 171
Joined: Thu May 25, 2006 8:02 am

Re: ADC-212 Not Found

Postby Guest » Mon Nov 26, 2007 10:45 am

We found that ADC212 (both: installation and installed) software gets confusion (Message: ADC212 is not connected), when two LPT ports are installed in PC. Disable the extra LPT port from device manage to solve the problem. This is a bug in ADC212 software.
Guest
 

ADC-212 not connected

Postby Guest » Fri Nov 30, 2007 1:43 pm

My PC crashed earlier this month. I had to reload Windows XP and have tried to get some of my other programs going.

I has so much trouble with Microsoft Money 2006 and the Microsoft help desk tha I finally bought another program for doing my check book. Microsoft is now a BAD word in my house.

Now I am trying to get my ADC-212 back up but I am having a lot of trouble with the Pico help desk.

Is there anyway to get the current software for the ADC-212? Nothing on this web site works and all the instructions I get from the help disk is either wrong or does not make sense.
Guest
 

Postby ziko » Fri Nov 30, 2007 3:47 pm

Hi I emailed you in the helpdesk.

Kind regards
Ziko

Technical Specialist
ziko
Zen Master
Zen Master
 
Posts: 1705
Joined: Fri Dec 01, 2006 10:03 am
Location: St Neots

WAITING FOR ADC

Postby Guest » Mon Feb 11, 2008 2:00 pm

hi

I'm having a similar problem. This time with a new laptop that doesn't have an LPT port connection. I am using a USB to Parallel converter but the ADC is still not seen on any of the USB-PPx ports
Guest
 

Postby picojohn » Mon Feb 11, 2008 4:08 pm

Hello Guest,

The Pico USB to parallel converter (http://www.picotech.com/usb_parallel_port.html) is the only device that will work.

Regards
John
picojohn
Zen Master
Zen Master
 
Posts: 382
Joined: Mon Jun 11, 2007 1:10 pm


Return to Getting Started

Who is online

Users browsing this forum: No registered users and 0 guests