Test and Measurement Forum

PicoScope Software Crash

Forum for discussing PicoScope (version 5)

PicoScope Software Crash

Postby jon_kennedy » Tue Aug 01, 2006 5:40 pm


I recently bought a ADC-42 and have been running it fine over the last couple of weeks using my colleagues (fairly old) laptop. I can't continue to do this however, so intended to use my own desktop computer (less than 1 year old, Windows XP, CAD station type spec). However, when I try this the software crashes when I try and use a timebase of 100ms/div or greater in either Standard or Block Mode. This didn't happen when I was using an older computer! All the other settings have been left at their default but even if I try different maximum sample limits etc. it still happens. If you could tell me if i'm doing anything wrong or can do anything to stop this happening I would appreciate it.


Jon Kennedy
Posts: 2
Joined: Tue Aug 01, 2006 5:31 pm

Postby Michael » Mon Aug 14, 2006 10:27 am

Hello Jon,

Thank you for your post.

Can you confirm the version of PicoScope you are using?

Also, check the parallel port mode in the PC BIOS settings. Try setting to Normal, Output only or Standard.

Best regards,
Michael - Tech Support
Pico Technology
Web Support Forum
Zen Master
Zen Master
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire

picoscope software crash

Postby jon_kennedy » Mon Aug 14, 2006 11:38 am

hello michael,

I have PicoScope 5.14.5 - 32bit, ADC10/12/40/42 Driver V3.2, pico.sys V2.1. I've also tried using older versions of the software but it didn't help.

I looked at the BIOS settings for the parallel port, the mode options were OFF, AP, PS/2, EPP, ECP so I wasn't sure which one to pick. I looked on my colleagues laptop (where PicoScope doesn't crash) and it was using ECP mode with DMA 3 so I tried these settings. Picoscope still crashed. I tried the DMA 1 and OFF options still under ECP and none of these worked, I tried the AT, PS/2 and EPP parallel port modes and PicoScope still crashed in any of these settings. I didn't try changing the Port address (it is 378), I don't really know what these changes are doing since my computer knowledge is fairly limited. It may be that I needed to make other changes to make the different parallel port modes work.

When I start up the DELL screen says it is running BIOS revision A06, don't know if this is useful information.

If you have any other suggestions of things to try I wouild appreciate it as this software problems is really holding things up.

Many Thanks

Posts: 2
Joined: Tue Aug 01, 2006 5:31 pm

Postby David Browning » Tue Sep 12, 2006 9:47 am

I have been using ADC42 to measure the time between 4 volt pulses downto 5 mS. It only just works on my windows 98se. Any attempt to use triggers results in the pc hanging. I have downloaded the latest Software no help. I then decided to run it on my Widows XP which is very stable. The problems just got much worse. It is now unusable !!

Suggest that Pico release ba patch to solve these problems.

I would consider purchasing a more modern device. the USB 16 channel device interests me but I am reluctant until I get some reasurance from Pico that their devices will work.

What do upou think Pico?

Kind regards

David Browning
David Browning

Postby Sarah » Wed Sep 13, 2006 10:59 am


There are a couple of things to address here. Firstly I recommend trying the other available modes in the BIOS for the parallel port. AP is one that has worked for other customers before now.

With regards the performance of the ADC-42, this unit has not onboard memory and thus has to transfer every sample straight to the PC. This creates a heavy load on the computer and thus leads to the results you are seeing. Due the the way XP works and handles it's ports, the problem can be worse on XP. The trigger issue again relates to the lack of a buffer memory - the computer has to spend every available resource looking for the trigger event and thus the computer appears to freeze. Once the trigger has occurred however, it will come back to life. If on repeat trigger then you should press the space bar and then cause the trigger to happen.

Our newer units all have large buffer memories and so do not encounter any of these problems. I would recommend upgrading to USB if you are able.

Best Regards

Return to PicoScope 5

Who is online

Users browsing this forum: No registered users and 0 guests