Test and Measurement Forum

scaling problem with equation in Picolog

Forum for discussing PicoLog

scaling problem with equation in Picolog

Postby maverick » Mon Jul 17, 2006 5:46 pm

Hi,

I used ADC11-10 and Picolog R.16 version, real-time continuous mode with sample rate=100ms, scan time=20000us.

I met a quite strange problem, when I scaling the load cell voltage to physical units(force in Newton) using scaling function in Picolog while recording that load cell voltage at the same time. I.e., I set two measurements using the same input channel, one is for original voltage output, the other is for scaling the voltage to force. I found that the scaled force data doesn't have high linear correlation with my recorded voltage data(R^2=0.77), it should be 1 since I just used the linear scaling such as force=voltage*10.

I further check the screen reading for scalled force value and original voltage value, it showed that they are not changed in the same time!! This makes me feel very frustrated. does anyone meet the similar problem as me? Is it the bugs in the Picolog? Why this happened?

I am eager to hear some solutions or suggestions! Thanks.

Best regards,
maverick
maverick
User
User
 
Posts: 4
Joined: Wed Jun 28, 2006 2:29 pm

Postby Michael » Tue Jul 18, 2006 10:10 am

Hello Maverick,

Please give us some mopre detail on this. Can you send us one of your PicoLog data files? This will help us to get to the bottom of this.

Best regards,
Michael
Michael - Tech Support
Pico Technology
Web Support Forum
Michael
Zen Master
Zen Master
 
Posts: 656
Joined: Thu Jul 07, 2005 12:41 pm
Location: St Neots, Cambridgeshire


Return to PicoLog

Who is online

Users browsing this forum: No registered users and 0 guests