xubuntu16.04 picoscope 6.11.13.3: "No suitable device found"

Discussion forum for the new Picoscope Linux software
Post Reply
simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

xubuntu16.04 picoscope 6.11.13.3: "No suitable device found"

Post by simon_u » Mon Aug 22, 2016 12:33 pm

starting picoscope as user or as root starts the gui with the message: "No suitable device found"

dmesg:

[ 1945.220454] usb 2-1: USB disconnect, device number 9
[ 1948.436102] usb 2-1: new full-speed USB device number 10 using ohci-pci
[ 1948.664144] usb 2-1: New USB device found, idVendor=0ce9, idProduct=1014
[ 1948.664159] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1948.664167] usb 2-1: Product: PICO DEVICE
[ 1948.664173] usb 2-1: Manufacturer: Pico Technology


sudo sh /opt/picoscope/share/doc/libusbdrdaq/usbtest

Getting user and group information...
- You are running this script as root.
- You are in the following groups:
root

****************************************************************************
RUNNING AS ROOT! *
* It is OK to run this script as root for testing purposes, but it is *
* neither recommended nor necessary to run the Pico USB drivers as root *
* once you have set your system up correctly. *
****************************************************************************


Please connect your Pico USB device and press enter to continue.../opt/picoscope/share/doc/libusbdrdaq/usbtest: 37: read: arg count

Pico USB device found: /dev/bus/usb/002/011

- It belongs to root (which is you) who has permissions rw-
- The members of group pico (which you are not in) have permissions rw-
- Everyone else has permissions r--
- You can write to this device and so will be able to use it.



Has someone an idea?

The Laptop has 8 years. Is possible the ports are usb 1.x

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Tue Aug 30, 2016 12:58 pm

Hi simon_u,

After the next session where the device is not recognised, could you please close the PicoScope software and post a copy of the trace.xml file which can be located here:

Code: Select all

~/.local/share/Pico\ Technology/260a68f1-30f-0a5e01d65514
Alternatively, you can e-mail the files to support@picotech.com

Just to confirm, is this the USB DrDAQ, and is it connected to a USB 2.0 or USB 3.0 port? Are you using the supplied USB cable?

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Sat Sep 17, 2016 8:06 am

Sorry for the late response

I confirm USB DrDAQ, and I connected it to a USB 2.0 and USB 3.0. I'm using the supplied USB cable.

I tried also the usbtest:

Code: Select all

Getting user and group information...
 - You are running this script as simon.
 - You are in the following groups:
     simon sudo pico

Please connect your Pico USB device and press enter to continue...

Pico USB device found: /dev/bus/usb/001/007

 - It belongs to root (which is not you) who has permissions rw-
 - The members of group pico (which you are in) have permissions rw-
 - Everyone else has permissions r--
 - You can write to this device and so will be able to use it.
simon@Xubuntu1604:~$ 
The trace.xml:



But I have a new problem: after a few starts from the picoscope-gui it doesn't start, on the terminal there ist the message:t

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Mon Sep 19, 2016 10:51 am

Hi Simon,

I was unable to find a trace.xml file attached. If you are able to locate it, that might be helpful.

What is the full message in the terminal window?

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Wed Sep 21, 2016 8:00 am

Sorry
I forgot to paste

Code: Select all


    Trace opened 17.09.2016.
    Running on Mono - True
    Mono Display Name - 2.10.8.1 (tarball Mon Jun  6 11:10:17 BST 2016)
    Host Operating System - Linux
    64Bit Operating System - True
    64Bit Process - True
    Logical Processors - 2
    Application 'PicoScope 6 Beta' (version 6.11.13.3) starting.
    4AA34CDA6FEDE55484D615F5AA876DEB
    User is not Guest
    No Administrator Privileges
    Failed to detect access rights
    OS Version - Unix 4.4.0.36
    .net Version - 4.0.30319.1
    Current Directory - /opt/picoscope/lib
    Command Line - /opt/picoscope/lib/PicoScope.GTK.exe
    Settings file version - 11.2.0
    Preferences file version - 2.0.0
    Probes file version - 1.0.0
    Data file binary header version - 1
    Creating Preferences file.
    Using default culture: English (United States).
    Begin
    Begin
    Complete
    Attempting to load ps6000.dll
    Finished loading ps6000.dll
    Opening device using DLL ps6000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps6000.dll
    Finished loading ps6000.dll
    Opening device using DLL ps6000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps5000a.dll
    Finished loading ps5000a.dll
    Opening device using DLL ps5000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps5000.dll
    Finished loading ps5000.dll
    Opening device using DLL ps5000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000a.dll
    Finished loading ps4000a.dll
    Opening device using DLL ps4000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000a.dll
    Finished loading ps4000a.dll
    Opening device using DLL ps4000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000.dll
    Finished loading ps4000.dll
    Opening device using DLL ps4000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000.dll
    Finished loading ps3000.dll
    Opening device using DLL ps3000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps2000a.dll
    Finished loading ps2000a.dll
    Opening device using DLL ps2000a.dll
    Opening PS2000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps2000.dll
    Finished loading ps2000.dll
    Opening device using DLL ps2000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load usbdrdaq.dll
    Finished loading usbdrdaq.dll
    Opening device using DLL usbdrdaq.dll
    usbdrdaq.dll OpenUnit returned 3
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load pl1000.dll
    Finished loading pl1000.dll
    Opening device using DLL pl1000.dll
    Opening device unsuccessful. Error UnitNotFound
    No of Devices Found: 0
    Complete
    Trace Closing
closed.

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Wed Sep 21, 2016 8:52 am

Thanks Simon,

Are you able to test the USB DrDAQ on another PC?

Have you tried swapping the USB cable?

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Wed Sep 21, 2016 4:31 pm

Yes,

I tested different kit's of drdaq's (we have bought 30 set for our scool), and different computers with xubuntu 14.04 and ubuntu 12.04. The problems at the moment remains.

The drdaq's works under windows. It seems to be an actual problem for linux.

An other interesting thing:
When I try to start as sudo then picoscope crashes with:

Code: Select all

sh: Zeile 1: 28689 Speicherzugriffsfehler  (Speicherabzug geschrieben) /opt/picomono/bin/mono /opt/picoscope/lib/PicoScope.GTK.exe 2>&1 > /dev/null
When then subsequently I start picoscope whitout sudo the crash remains. Only when I remove

Code: Select all

.local/share/Pico\ Technology/
the gui is able to start

regards

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Thu Sep 22, 2016 10:23 am

Hi Simon,

Could you please locate the trace.xml after the crash and post it back here?

It could be a permissions issue.

Is the device recognised when the software starts?

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Thu Sep 22, 2016 12:59 pm

a fresh trace.xml

Code: Select all


    Trace opened 22.09.2016.
    Running on Mono - True
    Mono Display Name - 2.10.8.1 (tarball Mon Jun  6 11:10:17 BST 2016)
    Host Operating System - Linux
    64Bit Operating System - True
    64Bit Process - True
    Logical Processors - 2
    Application 'PicoScope 6 Beta' (version 6.11.13.3) starting.
    4AA34CDA6FEDE55484D615F5AA876DEB
    User is not Guest
    No Administrator Privileges
    Failed to detect access rights
    OS Version - Unix 4.4.0.36
    .net Version - 4.0.30319.1
    Current Directory - /opt/picoscope/lib
    Command Line - /opt/picoscope/lib/PicoScope.GTK.exe
    Settings file version - 11.2.0
    Preferences file version - 2.0.0
    Probes file version - 1.0.0
    Data file binary header version - 1
    Using default culture: English (United States).
    Begin
    Begin
    Complete
    Attempting to load ps6000.dll
    Finished loading ps6000.dll
    Opening device using DLL ps6000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps6000.dll
    Finished loading ps6000.dll
    Opening device using DLL ps6000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps5000a.dll
    Finished loading ps5000a.dll
    Opening device using DLL ps5000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps5000.dll
    Finished loading ps5000.dll
    Opening device using DLL ps5000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000a.dll
    Finished loading ps4000a.dll
    Opening device using DLL ps4000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000a.dll
    Finished loading ps4000a.dll
    Opening device using DLL ps4000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps4000.dll
    Finished loading ps4000.dll
    Opening device using DLL ps4000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000a.dll
    Finished loading ps3000a.dll
    Opening device using DLL ps3000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps3000.dll
    Finished loading ps3000.dll
    Opening device using DLL ps3000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps2000a.dll
    Finished loading ps2000a.dll
    Opening device using DLL ps2000a.dll
    Opening PS2000a.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load ps2000.dll
    Finished loading ps2000.dll
    Opening device using DLL ps2000.dll
    Opening device unsuccessful. Error UnitNotFound
    Attempting to load usbdrdaq.dll
    Finished loading usbdrdaq.dll
    Opening device using DLL usbdrdaq.dll

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Fri Sep 23, 2016 9:03 am

Hi Simon,

Thanks for the information.

Have you tried running the PicoScope application as a super user?

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Fri Sep 23, 2016 1:12 pm

I tried picoscope as user: the gui start with the message

Code: Select all

 "No suitable device found"
I tried picoscope as superuser to: the application crash during the start with:

Code: Select all

sh: Zeile 1: 28689 Speicherzugriffsfehler  (Speicherabzug geschrieben) /opt/picomono/bin/mono /opt/picoscope/lib/PicoScope.GTK.exe 2>&1 > /dev/null
After the crash as superuser picoscope crash as normal user to.

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Tue Sep 27, 2016 9:51 am

Hi Simon,

I have reported a bug to our Development Team as I have been able to repeat the problem here after another Customer reported the issue.

I will look to provide an update as soon as possible.

Regards,
Hitesh

Software Dev. Engineer

simon_u
Newbie
Posts: 0
Joined: Mon Aug 22, 2016 12:21 pm

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by simon_u » Thu Jan 12, 2017 1:41 pm

Anything news?

One argument to buy drdaq was the compatibility to use it under linux. We bought 30 drdaq's for our scool.

Hitesh
PICO STAFF
PICO STAFF
Posts: 2855
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: xubuntu16.04 picoscope 6.11.13.3: "No suitable device fo

Post by Hitesh » Mon Jan 16, 2017 10:24 am

Hi Simon,

I have escalated the bug report.

There might be a new release of the software in the near future, but I do not have any information on timescales.

Regards,
Hitesh

Software Dev. Engineer

Post Reply