Test and Measurement Forum

Picomono/Picoscope6 on Ubuntu 12.04

Discussion forum for the new Picoscope Linux software

Picomono/Picoscope6 on Ubuntu 12.04

Postby mario_ » Tue Jul 26, 2016 10:47 am

Recent changes in the way Picoscope 6 for Linux is deployed brought a new requirement: picomono. This is collection of .Net libraries required to run PicoScope on Linux without conflicts from mono provided for particular OS. We had some reports that currently released picomono (2.10.8-1r02) is not installing on some older OS's (like Ubuntu 12.04). This is due to unmet dependencies for libcairo. In order to get it working, we have provided a separate build targeted only for Ubuntu12.04. (It still may work on other distributions/versions, but it is untested).

To get it:

  • Download package for your architecture:
    • 32bit
      Code: Select all
      wget https://labs.picotech.com/debian/extra/picomono_2.10.8-1r02~precise_i386.deb
    • 64bit
      Code: Select all
      wget https://labs.picotech.com/debian/extra/picomono_2.10.8-1r02~precise_amd64.deb
  • Pre-install the package:
    • 32bit
      Code: Select all
      sudo dpkg -i picomono_2.10.8-1r02~precise_i386.deb
    • 64bit
      Code: Select all
      sudo dpkg -i picomono_2.10.8-1r02~precise_amd64.deb
  • Resolve dependencies and finish installation:
    Code: Select all
    sudo apt-get -f install
  • Install picoscope as normal
    Code: Select all
    sudo apt-get install picoscope
mario_
Site Admin
Site Admin
 
Posts: 112
Joined: Fri Sep 13, 2013 12:57 pm

Return to PicoScope for Linux

Who is online

Users browsing this forum: No registered users and 0 guests