3406dmso USB issues

Forum for discussing PicoScope version 6 (non-automotive version)
Post Reply
robc
Newbie
Posts: 0
Joined: Fri Jul 15, 2016 7:21 pm

3406dmso USB issues

Post by robc » Fri Jul 15, 2016 7:27 pm

Need help with USB issues with the scope above. Using WIN10 connecting to 3.0 usb ports I get 'Unknown USB Device (Device Descriptor Request Failed'.
The scope is brand new. I've reinstalled software and made sure the USB drivers are up to date but no luck. Also same error on second PC.

Hitesh
Site Admin
Site Admin
Posts: 2810
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: 3406dmso USB issues

Post by Hitesh » Tue Jul 19, 2016 1:28 pm

Hi robc,

Have you tried connecting to USB 2.0 ports and using different USB cables?

If the above does not work, if you purchased the device from a distributor/re-seller, please contact them for a repair/exchange otherwise if it was purchased from us, please e-mail support@picotech.com with your order reference number, contact details and the serial number of the PicoScope device.

Regards,
Hitesh

Technical Support Engineer

Post Reply