PicoScope 3206D starting LV problem

Post your LabVIEW discussions here
Post Reply
Yury
Newbie
Posts: 0
Joined: Wed Jul 13, 2016 12:18 pm

PicoScope 3206D starting LV problem

Post by Yury »

Hello. I need help with my problem. When I run the example in LabView error occurs "Unable to open PicoScope".

P.S.
PicoScope 3206D
LabView 15.0 32bit
All needed dll's copied to LabView/resource directory.
PC restarted several times. Oscilloscope working perfectly with PicoScope 6.
Examples started by me from C:\Program Files\Pico Technology\SDK\src\PS3000\Labview.
If I start examples from C:\Program Files\Pico Technology\SDK\src\PS3000A\Labview (32 or 64, doesnt matter), then I got message that my 3206D not found (PICO_NOT_FOUND).
In both situations I tried to start PicoScope3000ExampleBlock/PicoScope3000aExampleBlock.
About PC: Core i7, Win7 x64, 8 Gb DDR3, USB 3.0, etc.
I hope i didnt forgot anything.

Please help! Thanks!

Martyn
Site Admin
Site Admin
Posts: 3865
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 3206D starting LV problem

Post by Martyn »

Check if the SDK installer added a directory C:\PicoSDK with the examples in, if so try running the examples from there, if not copy the examples to your normal LabVIEW applications directory, it may be folder permissions causing the issue.

Are you plugged into a USB2 or USB3 port?

Is the PicoScope application still running when you try to run the LabVIEW application?
Martyn
Technical Support Manager

JV-en-train
Newbie
Posts: 0
Joined: Thu Oct 24, 2019 10:22 am

Re: PicoScope 3206D starting LV problem

Post by JV-en-train »

I encounter the same issue with a 3203D. Did you eventually find the reason?
Connected over USB3.
The communication works fine with the PicoScope 6.14.5 tool.
Tried with the ps3000.dll from the SDK (got from github.com/picotech).
Tried with the ps3000.dll from C:\Program Files (x86)\Pico Technology\PicoScope6\
LabVIEW 2016 32bits, latest Windows 10. There is no LabVIEW error.
The failure is triggered within the DLL, when "ps3000_open_unit" is invoked.

Martyn
Site Admin
Site Admin
Posts: 3865
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: PicoScope 3206D starting LV problem

Post by Martyn »

You are referencing the 3000 series drivers and examples which are for a much older device, you need the 3000a examples for your device LabVIEW 3000a
Martyn
Technical Support Manager

JV-en-train
Newbie
Posts: 0
Joined: Thu Oct 24, 2019 10:22 am

Re: PicoScope 3206D starting LV problem

Post by JV-en-train »

Thank you, the connection works in fact with the ps3000a.dll

Post Reply