Test and Measurement Forum

PT-104 on Ubuntu 14.04 USB

Post any questions you may have about our current range of USB data loggers

PT-104 on Ubuntu 14.04 USB

Postby Luca Minzoni » Tue May 17, 2016 9:21 am

Good morning,
my name is Luca and i currently have an issue with my PT-104. When connected via USB to my pc, using UBUNTU 14.04, the software usbpt104con doesn't work anymore and i get the error:
GetValue: Status = 0x118

It worked in the previous days and i didn't change anything, but i tried ethernet connections with the device using the ethernet protocol. Thank you for helping, cheers
Luca.
Luca Minzoni
Newbie
 
Posts: 0
Joined: Tue Apr 26, 2016 1:21 pm

Re: PT-104 on Ubuntu 14.04 USB

Postby Hitesh » Wed May 18, 2016 9:23 am

Hi Luca,

The value 0x118 corresponds to PICO_WARNING_REPEAT_VALUE in the PicoStatus.h file.

This means that you might be requesting readings for a channel faster than the conversion time (720 ms per channel). Each channel is read in sequence so you will need to take this into account as well before requesting the next reading from a particular channel i.e. with all 4 channels enabled, it would take just over 2.8 seconds before you can take a reading on channel 1.

The drivers should have been updated recently so please try updating the libusbpt104 package on your PC.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PT-104 on Ubuntu 14.04 USB

Postby Luca Minzoni » Wed May 18, 2016 10:09 am

Thank you very much for the answer, now it works fine without any change. I suppose the error was due to a problem with my pc, however i will update the package. Best regards,
Luca.
Luca Minzoni
Newbie
 
Posts: 0
Joined: Tue Apr 26, 2016 1:21 pm


Return to USB PC Data Loggers

Who is online

Users browsing this forum: No registered users and 0 guests