Test and Measurement Forum

PicoScope6 SDK for debian armhf (BananaPi) outdated

Come here to introduce yourself, who you are, and what you do

PicoScope6 SDK for debian armhf (BananaPi) outdated

Postby bo911 » Wed May 04, 2016 7:37 am

Hello Forum,

I bought a new somehow up to date 2206BMSO PicoScope with the recording via
BananaPi (Bananian, debian jessie 8.4) through the UBS Port in mind ...

After downloading / install via apt-get I'm a little frustrated, because :

1.) I added the hopefully correct apt source deb http://labs.picotech.com/debian/ picoscope main
2.) If I want to install picoscope with apt-get install picoscope =>
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
picoscope : Depends: libpl1000 (= 1.0.8-1r06) but 1.0.8-1r11 is to be installed
Depends: libps2000 (= 2.1.5-3r06) but 2.1.5-3r12 is to be installed
Depends: libps2000a (= 1.1.5-5r28) but 1.1.5-5r36 is to be installed
Depends: libps3000 (= 3.7.6-3r05) but 3.7.6-3r10 is to be installed
Depends: libps3000a (= 1.4.5-6r45) but 1.4.5-6r53 is to be installed
Depends: libps4000 (= 1.2.5-2r18) but 1.2.5-2r23 is to be installed
Depends: libps4000a (= 1.0.5-2r31) but 1.0.5-2r42 is to be installed
Depends: libps5000 (= 1.5.5-3r16) but 1.5.5-3r21 is to be installed
Depends: libps5000a (= 1.1.5-5r24) but 1.1.5-5r34 is to be installed
Depends: libps6000 (= 1.4.5-6r34) but 1.4.5-6r37 is to be installed
Depends: libusbdrdaq (= 1.0.5-1r06) but 1.0.5-1r12 is to be installed
E: Unable to correct problems, you have held broken packages.

=> The available lib - packages are newer than the picoscope package and therefore
no luck at all !! :cry:
3.) Then I tried to get the samples running by using the libps2000a under /opt/picoscope/....
=> after installing the required development tools I got the sample ps2000acon Program
compiled + installed, but there is no support at all for the PicoScope 2206BMSO !! ??
To verify, that the software is build OK, I use another PicoScope 2208 and the sample
Program is running ....

My question now is:
a.) Is there any hope to get the somehow new PicoScope 2206BMSO suported versions of the software
also for linux ? (especially x86_64, armhf)
b.) Is there any picoscope repo useable for armhf ??

The PicoScope is advertised to work on linux, but the newer modells didn't, so this was the key feature
for me to buy one !!
Hope for some usefull information(s) .... :D
bo911
User
User
 
Posts: 2
Joined: Wed May 04, 2016 7:06 am

Re: PicoScope6 SDK for debian armhf (BananaPi) outdated

Postby Hitesh » Mon May 09, 2016 1:53 pm

Hi bo911,

A PicoScope 6 for Linux version supporting the PicoScope 2206B MSO should be out soon, but please note that it will not be available for hardware platforms like the Raspberry Pi, so you would have to use a standard Linux build for this.

There will be armhf drivers available for these devices as well. They should be downloaded and installed via the relevant install command or you can download them from this page once they are available.

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2058
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: PicoScope6 SDK for debian armhf (BananaPi) outdated

Postby bo911 » Tue May 10, 2016 7:34 am

Thanks for the Information(s)

with available drivers for armhf I would be happy .... :D
bo911
User
User
 
Posts: 2
Joined: Wed May 04, 2016 7:06 am


Return to Introductions

Who is online

Users browsing this forum: No registered users and 2 guests