Test and Measurement Forum

Math Function Filter, Syntax Error

Forum for discussing PicoScope version 6 (non-automotive version)

Math Function Filter, Syntax Error

Postby Juergen » Fri Apr 15, 2016 8:04 am

Hello,

I am using PicoScope 6.11.12.1692 in a German Language Installation.

I have tried to use the Math Channel function LowPass Filter, but when I set it up e.g. LowPass(A,100)
Filter.png

like it is shown
in the documentation, I get a Message Syntax Error and the Next Button is greyed out.

So what I am doing wrong?
Juergen
Newbie
 
Posts: 0
Joined: Fri Apr 15, 2016 7:42 am

Re: Math Function Filter, Syntax Error

Postby Hitesh » Wed Apr 20, 2016 10:01 am

Hello Juergen,

The software is indicating an error as the comma separator is used as a decimal separator by your regional settings.

Try using a semi-colon ';' in place of the comma.

Hope this helps,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2490
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Math Function Filter, Syntax Error

Postby Viech1973 » Thu Jan 26, 2017 10:20 pm

Hi,

I have the same configuration (German Windows), this trick has helped me in the past.

I just installed PicoScope 6.12.5.2458, and it does not work any more.

Both

LowPass(A,100)
and
LowPass(A;100)

give an "Invalid Formula" error.

I tried switching PicoScope to English, this did also not work.

Any tips?

Thank you
.thomas
Viech1973
Newbie
 
Posts: 0
Joined: Thu Jan 26, 2017 10:15 pm

Re: Math Function Filter, Syntax Error

Postby Hitesh » Wed Feb 01, 2017 5:22 pm

Hello Thomas,

What regional language settings are you using in Windows?

Regards,
Hitesh

Technical Support Engineer
Hitesh
Site Admin
Site Admin
 
Posts: 2490
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Math Function Filter, Syntax Error

Postby MikeHE » Sun Feb 12, 2017 3:06 pm

Hello,
i have the same problem.
PicoScope Version: 6.12.5.2630 German running on Win 7 Pro 64Bit German.
All regional and langauge settings are "german".
The decimal separator at the regional settings is ","
LowPass(A,100), LowPass(A;100), LowPass(A.100), LowPass(A 100) ist not working.... :-(
Any tips?

Thanks Mike
MikeHE
Newbie
 
Posts: 0
Joined: Sun Feb 12, 2017 2:53 pm

Re: Math Function Filter, Syntax Error

Postby hin » Wed Feb 15, 2017 2:32 pm

Hello,

at first, switched from a Velleman USB oscilloscope to a 2204A, which is a different class ! Great SW, great handling, really a replacement for a 5k€+ digital oscilloscope !
But also stumbled over above issue, cannot activate any filter, which is a shame. Signal filtering is an important tool, so please help.

Many thanks and best regards
Gerhard
hin
Newbie
 
Posts: 0
Joined: Wed Feb 15, 2017 2:17 pm

Re: Math Function Filter, Syntax Error

Postby MemorX » Thu Feb 23, 2017 10:15 am

I was also struggeling with this issue, using:
Windows 7 Enterprise SP1 64 Bit, English
PicoScope 6.12.7.2687 English

As long as my reginal settings (format) were set to my preference (Norwegian, Bokmål) the filter i get the "invalid formula" error. Restarting PicoScope with the format changed to English (United States) or English (United Kingdom) "LowPass(C,100)" is accpted, but the "," is changed to a ";" automatically when finishing the dialog.

Setting the format back to Norwegian, Bokmål, then changing the Decimal symbol in "Additional settings" from "," to "." solved the issue. The "," is still changed to a ";" automatically when finishing the dialog.
MemorX
Newbie
 
Posts: 0
Joined: Thu Feb 23, 2017 8:38 am

Re: Math Function Filter, Syntax Error

Postby Martyn » Mon Feb 27, 2017 9:51 am

The development team are aware of the issue and are working on a solution. This will appear in a future release of the software.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2781
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Math Function Filter, Syntax Error

Postby hg_from_g » Sat Jul 15, 2017 5:15 pm

Dear forum,

math filter still doesn't work neither in PicoScope 6.12.9 nor in PicoScope 6.13.0 beta :-(. I bought this scope because you promoted it on datasheet !!! Now I see since more than 15 months nobody can use it on every scope. Is that really true?
PicoScope_manual_filters.jpg
Manual PicoScope 3000 series: promoted math filters

What's the last version of PicoScope it works and where i can download? When do you fix it???

hg
hg_from_g
Newbie
 
Posts: 0
Joined: Thu May 25, 2017 10:27 am

Re: Math Function Filter, Syntax Error

Postby Martyn » Wed Jul 26, 2017 10:23 am

Please email support@picotech.com giving details of your setup and the team will be able to advise the correct option.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2781
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots

Re: Math Function Filter, Syntax Error

Postby den » Mon Oct 30, 2017 10:44 am

Stumbled across this issue in the current 6.12.9 and 6.13.1 beta in demo mode as i am evaluating it for a purchase.

My Windows 7 Settings are German (Decimal char: ",", Grouping ".", List separator ";", same in the tab for currency). As many Office products heavily rely on those settings, i do not want to change those, although some versions allow deviation from the system setting. I tried both PicoScope settings for German and English, no change there.

I understand that such settings can be quite far reaching into things like CSV import and export or practically any value displayed, but e.g. there are so many variations for csv in the wild (the "text to columns" feature of spreadsheet applications gives quite some insight), that it might make sense to configure them separately per application.

Being unable to use any function in the maths channel creation that takes more than one argument is quite a setback for this otherwise good product.

P.S.: found this topic from 2014/2016 but it seems the solution is missing again in the versions i tested.
den
Newbie
 
Posts: 0
Joined: Mon Oct 30, 2017 10:02 am

Re: Math Function Filter, Syntax Error

Postby Martyn » Mon Nov 06, 2017 9:10 am

We are aware of this issue, so hopefully it will be resolved soon.
Martyn
Technical Support Manager
Martyn
Site Admin
Site Admin
 
Posts: 2781
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests