Test and Measurement Forum

Math Function Filter, Syntax Error

Forum for discussing PicoScope version 6 (non-automotive version)

Math Function Filter, Syntax Error

Postby Juergen » Fri Apr 15, 2016 8:04 am

Hello,

I am using PicoScope 6.11.12.1692 in a German Language Installation.

I have tried to use the Math Channel function LowPass Filter, but when I set it up e.g. LowPass(A,100)
Filter.png

like it is shown
in the documentation, I get a Message Syntax Error and the Next Button is greyed out.

So what I am doing wrong?
Juergen
Newbie
 
Posts: 0
Joined: Fri Apr 15, 2016 7:42 am

Re: Math Function Filter, Syntax Error

Postby Hitesh » Wed Apr 20, 2016 10:01 am

Hello Juergen,

The software is indicating an error as the comma separator is used as a decimal separator by your regional settings.

Try using a semi-colon ';' in place of the comma.

Hope this helps,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2225
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Math Function Filter, Syntax Error

Postby Viech1973 » Thu Jan 26, 2017 10:20 pm

Hi,

I have the same configuration (German Windows), this trick has helped me in the past.

I just installed PicoScope 6.12.5.2458, and it does not work any more.

Both

LowPass(A,100)
and
LowPass(A;100)

give an "Invalid Formula" error.

I tried switching PicoScope to English, this did also not work.

Any tips?

Thank you
.thomas
Viech1973
Newbie
 
Posts: 0
Joined: Thu Jan 26, 2017 10:15 pm

Re: Math Function Filter, Syntax Error

Postby Hitesh » Wed Feb 01, 2017 5:22 pm

Hello Thomas,

What regional language settings are you using in Windows?

Regards,
Hitesh

Technical Specialist
Pico Technology
Hitesh
Site Admin
Site Admin
 
Posts: 2225
Joined: Tue May 31, 2011 3:43 pm
Location: St. Neots, Cambridgeshire

Re: Math Function Filter, Syntax Error

Postby MikeHE » Sun Feb 12, 2017 3:06 pm

Hello,
i have the same problem.
PicoScope Version: 6.12.5.2630 German running on Win 7 Pro 64Bit German.
All regional and langauge settings are "german".
The decimal separator at the regional settings is ","
LowPass(A,100), LowPass(A;100), LowPass(A.100), LowPass(A 100) ist not working.... :-(
Any tips?

Thanks Mike
MikeHE
Newbie
 
Posts: 0
Joined: Sun Feb 12, 2017 2:53 pm

Re: Math Function Filter, Syntax Error

Postby hin » Wed Feb 15, 2017 2:32 pm

Hello,

at first, switched from a Velleman USB oscilloscope to a 2204A, which is a different class ! Great SW, great handling, really a replacement for a 5k€+ digital oscilloscope !
But also stumbled over above issue, cannot activate any filter, which is a shame. Signal filtering is an important tool, so please help.

Many thanks and best regards
Gerhard
hin
Newbie
 
Posts: 0
Joined: Wed Feb 15, 2017 2:17 pm

Re: Math Function Filter, Syntax Error

Postby MemorX » Thu Feb 23, 2017 10:15 am

I was also struggeling with this issue, using:
Windows 7 Enterprise SP1 64 Bit, English
PicoScope 6.12.7.2687 English

As long as my reginal settings (format) were set to my preference (Norwegian, Bokmål) the filter i get the "invalid formula" error. Restarting PicoScope with the format changed to English (United States) or English (United Kingdom) "LowPass(C,100)" is accpted, but the "," is changed to a ";" automatically when finishing the dialog.

Setting the format back to Norwegian, Bokmål, then changing the Decimal symbol in "Additional settings" from "," to "." solved the issue. The "," is still changed to a ";" automatically when finishing the dialog.
MemorX
Newbie
 
Posts: 0
Joined: Thu Feb 23, 2017 8:38 am

Re: Math Function Filter, Syntax Error

Postby Martyn » Mon Feb 27, 2017 9:51 am

The development team are aware of the issue and are working on a solution. This will appear in a future release of the software.
Martyn
Technical Specialist
Martyn
Site Admin
Site Admin
 
Posts: 2591
Joined: Fri Jun 10, 2011 8:15 am
Location: St. Neots


Return to PicoScope 6 for Windows

Who is online

Users browsing this forum: No registered users and 0 guests